Can't authenticate with desktop apps


For the last two days I have been unable to authenticate using the desktop apps.

  • Simlink
  • Charts
  • In game Charts
  • Navigraph HUB

It started suddenly by Simlink requested authentication while I was using the computer yesterday. (Not in conjunction with a login or restart of the computer.)

Error message from charts: Unable to sign in with device flow. Network Error.
Login page in the browser are not opened.

FMS Data Manager and web based apps (Charts and Simbrief) are working fine.

I have done the following:

  • Reinstalled apps Charts, Simlink and Hub.
  • Checked computer time and date
  • Checked firewall settings. (All outbound connection allowed. Inbound connection allowed for specific apps)


Hello! Thanks for the feedback.

Could you try using a different network for your computer? For example, try tethering your phone’s internet connection and use that instead.

Are you, to your knowledge, behind any proxies? Have you used any reverse proxies to debug the network communications of some other application?

Additionally, could you send the log file from one of the apps, say the Charts app for example?
To do that, please follow these steps:

  1. Press Win + R
  2. Type %appdata%/Navigraph Charts/logs and press enter
  3. In the Explorer window that opens, locate the main.log file
  4. Upload this file to your next post

Apologies for this inconvenience, let’s try to get it resolved!

Kind Regards,

Problem solved.
It was a problem with the DNS provided by my ISP. Changing to the Google DNS solved the problem.


1 Like

Great, thanks for sharing your solution!

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.