Blank map in the new panel

What I expected to happen.

The map should show VFR or IFR map styles

What actually happened

The map display is blank and only shows the flight plan route

1 Like

Installed and logged in fine but when I bring up the in game panel there is no actual map showing up in any modes (IFR or VFR).

All the other controls are there. I have tried zooming out and in but no difference, just a blank map screen.

Also tried restarting game.

This is with the latest release. Old official release removed.

Attaching a couple of screenshots if any use, (you can ignore the currently loaded flight plan, I just loaded that to see what can be seen. You can see the lines of the plan itself but no map. I then click the flashing triangle to locate my exact position, still blank):

after installing the new version (Beta 8) I noticed that there is no background relief in the in-game panel version, on the other hand the desktop version works well. did i miss something?
thanks in advance

Same. Been using the beta for a while now, with v18.6 installed. First time I’ve seen this, though - no map displayed. Charts are OK, but not map. Also, I can’t move or resize the panel now, and the close, pop-out, minimise toolbar buttons don’t work. Sim restarted and same.

Must be a server issue - after closing the panel and reopening it from the in-sim toolbar, some map tiles appear momentarily and then disappear. I’m also being asked to repeadedly sign-in now too. (Pancake, not VR mode, btw)

Having this same issue in VR - the world map isn’t visible.

We have made an attempt to fix the blank map now, please try it again. Unfortunately, it is hard for us to debug since we cannot reproduce it ourselves and Amazon is actually responsible for getting the map content out there.

Please let us know if the situation has improved!

Moved some posts from the main beta thread to this topic in order to stay organized, apologies for any inconvenience this might cause!

1 Like

As someone who was facing this issue yesterday, I wanted to post an update today that the map is working for me at present. Thanks team!

1 Like

Thank you for the update.

Happy New Year


I will consider this solved and closed as the result of an update that we did about 2 weeks ago.

Thanks for the feedback, everyone!