After SimLink Update, Navigraph Charts Message "Could not connect to simulator!"

Simlink updated to version 1.1.24.0118, after which moving map feature is unavailable in Charts or the in game panel.
I uninstalled, deleted folders, and reinstalled: same issue.

image


Where can I find the earlier Simlink version to see if this still functions OK?

Hi,

It looks like there is some Simlink configuration issue. Please follow troubleshooting points to fix it,

1. Close Simlink and running Simulator.
2. Open AppData folder and take backup of Navigraph folder.
  a. To open the AppData folder,
    i. Press the Win+R key, it will open the Run window.
    ii. Now type %appdata% and press enter.
3. After getting a backup of the Navigraph folder from AppData, delete the Navigraph folder.
4. Now start Simlink and reinstall plugins for Simulators.
5. Run Simulator and check Moving Map functionality with Navigraph Charts Application.
6. Done :slight_smile:

Please let us know the result after applying the above troubleshooting points.

TR,

Ahir Vishal D.
Navigraph

Confirm the correct folder is AppData\Roaming\Navigraph?

Did exactly as you described… still no connection.


image

Unless you have a fix in mind, can you send me the pervious version I can check if connection is resolved?

Is there a changelog for the new SimLink? I updated yesterday and now i am facing issues that my airplane is way beside the simbrief generated route. And also Volanta premium dont pick up all my waypoints.

Regards

Patric

for me the same, after update simlink nothing work anymore. I have tried all above but no succsess.
I have also tried a lot of work arround, but nothing will work. Please help, I need your great tool for my dayli flights.
simlink_2022-01-19.dlog (2.5 KB)

How many here with problem, are on Windows 11? I’m on Win 11 developers preview. No simlink connect.

There seems to be an issue related specifically to Win 11 dev preview. We are investigating. We don’t see this issue in the final Windows 11, so if an upgrade is an option for you then that would resolve it in the meanwhile.

Regards,

Stephen

The same thing happens to me, every time there is an update, goodbye to the connection with the simulator. I’m thinking about not continuing with the subscription.

Mampco, are you on Win 11 dev preview build?

Yes I am, but it’s not the first time it happens, and then they fix it, and it still works, but every time I lose days of being able to use it.

Same problem but fixed after uninstalling the Navigraph file in app data then restarting Navigraph Simlinker (scan) all ok.
My question is how can I find what version of Navigraph Simlink I now have installed ?
Bob

Hi Bob,

In Windows Show Hidden Icons bottom right next to Systray, click on green Simlink icon

image

See Navigraph Simlink Status:

Cheers
Ian

Hey please tell me. Are you on Win 11 dev preview build? And you say moving maps is working for you?

Hi Stephen

Vishal managed to get my installation working with the latest Simlink after several other efforts by pasting a new copy of the .exe over the installed one in the Navigraph folder. I don’t know if this will help other users or not…

One of the reasons for being on the dev OS version is to see early what issues are coming down the pipeline for my company’s software, so changing is not an option for me or many others. All other apps that I regularly use (for work and for play) are fine on the dev OS versions, and I have very rarely have issues that stop functionality, except I have had this twice with Simlink connection. While I certainly understand that you cannot support preview/dev builds, this early use/testing is a great indicator as to where improvement can be made to Navigraph software to be robust and ensure user satisfaction, especially as in my case my annual spend for charts exceeds any other game expense, including purchase of the MSFS2020.

I applaud your business model, with good recurring revenue. Given what we pay monthly/annually, we users therefore expect the software to be sufficiently robust, and at least as robust as other paid software.

I don’t know if this will work for you too, but Vishal from support pasted and “fresh” copy of the .exe over the installed one, and then connection was OK…

Hi,

We are have an internal build of a new Simlink version which should resolve the issues with Windows 11 dev preview. Will post back here soon.

Regards,
Stephen

1 Like

Thanks Stephen. Good news.

Thanks for your email.