Small bug in current version of MSFS panel

When you minimize the in-game panel with the “-” button in the top right of its window, it turns off/de-selects the “moving map” button. Once you turn it back on manually, it stays on no matter how many times you minimize or maximize the panel. :slight_smile:

Hi…,

Welcome.

The Navigraph In-Game Panel is a work in progress. I am not getting that behaviour. Maybe a reinstall of Simlink will fix this.

Also please note that Ctrl-N toggles the In-Game Panel display.

Cheers
Ian

thanks Ian. just thought I would let you know that this occurred on 3 fresh installs of MSFS on a completely fresh OS install as well, with no other addons installed. (reason for reinstalls, long story short - had PC stability problems, was trying to troubleshoot them). each time reproduced the (small) bug.

i do have the MSFS UI scale option reduced to 60, perhaps this is relevant?

Hello Molly! Welcome to the forum.

What you’re describing is, at least partially, intended behavior. The panel is supposed to stop the moving-maps function when the panel is minimized, and it is supposed to restart it when the panel is reopened.

The technical reason for this is that the environment that MSFS provides for these panels is single-threaded, meaning that the network traffic that is required to show your location actually has an effect on your FPS. That’s why we opted to disable the function when the panel is minimized to not use unnecessary resources, as you can’t see your location anyways!

With the above said, the behavior that you describe is not the intended one. Thank you for your feedback!
However, I am currently not able to reproduce it. Could you kindly record it somehow? Here’s what I’m seeing:

Kind Regards,
Malte

Here’s a short clip:

Hmm, okay I must admit that I am not fully following what the issue is in that clip. In contrast to what the clip shows, what would you expect from the panel in this situation?

In your clip, it can be seen that the moving-maps function is toggled every time you maximize/minimize it in a way that makes sure that it is turned off when the map is not visible. When you open it again, the feature is turned on again. Am I understanding you correctly in that you would expect it not to turn on again automatically?

I’m sorry for having a hard time understanding this, but please help me out! I’d love to help!

Kind Regards,
Malte

Watch the first time the window is minimized. The moving map feature does NOT turn back on automatically. It only does so every subsequent time, as I described in the OP. Thanks :slight_smile: