SimLink Update on 3/29 is crashing X-Plane 11

Good Morning! There was a SimLink Update that was pushed this morning that appears to be crashing X-Plane 11.52. I ran the installer and about 1-2 minutes after fully loading the sim X-Plane would crash. At first I thought it was the plane I was using, so I tried three different aircraft, same response all three. I removed the Simlink XPL and no more crashes. I am running a flight right now (without the plugin), but I will try and load a new one up in a bit with the plugin and grab a log file.

1 Like

same with my version, running vulkan

as soon as the plane was supposed to appear loaded, xplane crashed, i thought maybe the scenery was faulty, moved across the globe, same results, different plane, same result… soon as i remembered i pushed the update, and deleted it, poof, flight ready

Same here…as soon as i installed it it startet crashing the sim immediately. Removing it stops the issue. Nice update^^

Also crashing P3Dv4.5…

Jim B.

Same here XPlane 11.52.
Crashes immediately after loading.
Removing SimLink fixes it, so definitely the update

Yep, same here. The newest update as of 03/29/21 is crashing my X-Plane 11.53r1.
I doubled confirmed this, a friend of mine is on the same XP build and the lastest update of simlink and it is doing the same thing for him.


Sorry to hear, we’re investigating. Could you please start Simlink again, open Simlink Status window and go to the Settings tab. Check ”enable Simlink logs".

Start your simulator again, and if it crashes, please upload the latest 2 logfiles found in C:\Users\<username>\AppData\Roaming\Navigraph\Simlink\logs here.



Here you go,
Crashed on X-Plane 11.52r1Navigraph (825 Bytes)

Same issue for me.logs.7z (376 Bytes)

Also crashing P3Dv5.1…

Here are mine if it makes a difference logs.rar (505.2 KB)

Xplane 11.53 is crashing on my end too with latest Navigraph simlink.Vulkan Beta_20210329063037_log.txt (144 Bytes)

Same issue here. I almost reinstalled Xplane.

Crash here too… (3.5 KB)

Good to know this is the cause of my crashes after loading today. I’ve been pulling my hair for 2 hours wondering what’s going on then I remembered that I installed an update for simlink.

Same thing for me, XP 11.52 crashes to desktop once loaded into the sim at the ramp even when using the Default Cessna.

Same issue here. Hope we’ll see a fix soon.

Noticed the weird crashing issues as well, event viewer pointed too clr.dll when the sim crashed, did some googling and ran into this topic. I got a prompt too update 2 crashes later. Currently on seems like the update fixed it the crash. Sim has been up for a few mins and no crash atm.


Seems a general sim issue, also crashing my P3D5.1 on launch.

Rolling back to version 1.1.19 fixes the crashing, I think navigraph has rolled back the 1.1.20 version and is now pushing out the older simlink. Just be sure b4 installing if asked to update it does not say “will install”