Simlink update error

When I started Simlink today I was informed that there was an upgrade to and downloaded it. It looks like the downloaded file is, however.

After installing that I continue to get the update notification and the product version under properties->details is listed as with today’s date.


Hi Rich,

Can you please download Simlink again?
It will download lettest one.


Vishal Ahir


All set.

1 Like


I have also problems with Simlink, but also with Navigraph Charts and Simhub. Both on PC and Mac.

1./ Simhub starts up in 5 instances. (I saw that when I used Ctrl Als Del). The instances remain active when I close the program. After that I can start it up, but I do not see the window anymore.

2./ Navigraph charts does start up, but I do not see the window.

3./ Simlink starts up with startup. However it freezes. I can open the window, but after that nothing.

Last saturday I reinstalled everything, It worked, but now it does not anymore today, same problems all over again.

I discovered this because my connection with the Mac suddenly did not work anymore.

1./ Charts asked for Simlink. I could not find it on my system anymore. (I could not remember ever installing it).

2./ I installed Simlink, it could not connect with my simulator, however it seemed to work fine. Chars kept asking for Simlink.

3./ When I reinstalled everything on the PC, it worked fine.

Today I had to login to Simlink all over again. The only think what seems to be working is the connection with Simbrief. I discoved that again there was no connection. When I checked the PC’s software, the same problems where back.

Today I did not reinstal everything on the PC, because I wanted to do a flight without flightplan. But this is not what is supposed to happen, that I have to reinstal everything everytime. So I hope you can help me.

I still have the same problems. I only have to reinstall charts and simlink on the mac everytime, but still. Unfortunately nobody picked my post up

There is a slight improvement biw. I only have to sign out and in at simlink.


Sorry for overlooking your original post.

There seems to be some issues with your Windows installation. Navigraph Charts, Hub and Simlink are very different apps sharing little or no code. It seems they all seem to misbehave on your system, and this is not something you should expect of course, and it is not normal.

It would be helpful if you could provide some more information on when suddenly problems appears. You say that after complete reinstall everthing is fine, until suddently it is not. Does anything else happen on your system at the same time as the apps show problems? Is it a computer restart?

Sometimes antivirus software or firewalls can cause strange issues like these. Please temporarily disable these to see if it improves the situation.

Kind regards,


1 Like

3 posts were split to a new topic: Problem running Simlink on older MacOS

Hello Stephen,

Strangely enough I think I found the problem. It is a combination of indeed a virusscanner, bitdefender and the Base package of FSLTL which is causing a kind of problems. (I could not use the windows knob on my keyboard of screen anymore, could not start any programs, and programs on the background freezed). I use the injector in combination with the aircraft of FS traffic and did not experience many of the problems. The only thing what persists is that I have to log in simlink everytime. and cannot find the checkbox to keep it logged in. However, that is a small problem.

I will keep monitoring it. If the problem returns I will send you a new message. However since I discovered it yesterday, all problems seemed to have said goodbye.

Ok Stephen, I think after extensive testing the problem has gone away. Both Simlinks on the Mac and PC keep logged in aswel. So everything is solved (I hope).