SimLink not starting with Windows

So I recently updated SimLink and since then I’ve noticed it is not starting with Windows, so not running with MSFS, so my position is not showing on the maps/charts.

I have the Start Simlink with system startup of course (same as it’s always been) but it’s not starting. If I manually start it, it all works as normal.

I’ve tried uninstalling, downloading the latest version again and reinstalling, but no change.

Any suggestion please?

@Ian @skysail Bump! Hey guys, I would have hoped for a reply to my issue within 20 days.

Please can you advise?

Hi Craig! Sorry for the delay and thanks for the bump, this post somehow slipped through unnoticed.

I assume that you have the Start Simlink on system startup option selected, as you seem to have already mentioned. Which OS are you on, Win 10 or 11?

Please open task manager and

  1. Press Ctrl + Shift + ESC
  2. In the window that opens (Task Manager) select the startup/startup apps tab.
  3. Look through the list for an entry that says NavigraphSimlink.exe and then look to the right of it - what is the status? Enabled or disabled?

Again, sorry for the delay!

Kind Regards,

So in the settings, start with windows was enabled, but in the Task Manager it was disabled. That explains it!

UTCTK error (User Too Close To Keyboard), sorry.

Thanks for the quick reply.

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.