Simlink not connecting

Hello,
I am a new user of Navigraph. For the life of me, i cannot make simlink connect on my Windows 10 desktop, although i have read most of past topics and followed their steps. I attach a picture for your convenience.
Regards,
Aristomenis

reinstall and install again…

unistall first and so install agian :slight_smile:

I had already done that, and also deleted the roaming folder. No luck

Hi Aristomenis,

Welcome to our new forum.

Please:

  1. See FAQ - Simlink Install and Systray
  2. In Navigraph Simlink Plugin Settings, for your FS entry press Uninstall Simlink.
  3. Use Windows to uninstall Simlink.
  4. If they exist delete folders c:\Users\username\AppData\Roaming\Navigraph\Simlink and c:\Program Files\Navigraph\Simlink
  5. Download and install latest Simlink .

Please let us know how you get on

Cheers
Ian

Hey Ian,

I’ve spent countless hours trying to get Simlink to marry up with Xplane 11…I’ve done what feels like EVERYTHING I can to figure it out but nothing is working…I bought Xplane 11 off steam but when I put file where Xplane 11 is, it just says could not connect to simulator…I’ve uninstalled the application and the files multiple times…i don’t know what to do anymore,

Take care,

Kyle

No sir , seems like nothing work on it, I think there is a problem with new version of Simlink because the previous version was very efficient and so easy to work with .

Hello. I already needed your services to connect SimLink to my X-Plane 11 simulator installed on my iMac (os BigSur). It worked perfectly thanks to the intervention of Vishalahir. I would like to repeat this operation to connect SimLink on the same simulator installed on my MacBook Pro (os BigSur). Can you help me again? Thank you in advance.

Hi Team,

We are testing a new version of Simlink for macOS.

In the meantime please download and install Charts and Simlink for macOS

Cheers
Ian

Hello Ian.

Thank you for your reply. I therefore await your news regarding the availability of this new version of SimLink for mac os x.

I have already installed the latest version of Charts and SimLink for Mac on my MacBook Pro.

See you soon.

Jean-Luc

Ian, I am writing to you with an old issue. For the life of me I cannot seem to get Simlink to function properly. Let me elaborate… We had a lengthy exchange a while back which included live support from one of your technicians. That succeeded in getting Simlink to work on my iMac (running OS 11.1 Big Sur). The culprit was my settings within Firefox. Lately I noticed that I could not get the Navigraphs Charts app to display the moving aircraft icon. Also, I see no icon in my Mac Menu Bar. So I did a complete reinstall of both Charts and Simlink. Still no connection.

A question about this… previously when I was able to see the link and the icon I had a file within my XPlane11 Plugins called Navigraph Simlink_64.xpl. After the reinstall that is no longer there. Also I do not see any evidence of Simlink within my XPlane11 dropdown menu. I should point out that my working edition of XPlane is located on an external USB drive. Do I need to install Simlink on that drive as well or instead of on my Hard Drive Applications folder? I must say this is all a profound mystery to me and I do need your assistance to sort it out. Please explain exactly what I need to do to restore this capability within Navigraph Charts.

Best,
Steve Haines

Ian,
A brief update to my earlier note. After looking through my Firefox Browser settings with a fine tooth comb I discovered that while Navigraph Charts and Simbrief were listed as approved applications in the Preferences, the icons indicated were generic placeholders. After double clicking the entries, relinking them to the two applications, I am finally able to see the Simlink Icon in the Mac Menu Bar. However I cannot seem to open it. First, in order to see the icon I must have XPlane running. The icon then appears. But each time I try to open the window the curser changes to a spinning wheel and it refuses to open. Also, when I open the Nav Charts app and try to link it to XPlane it throws up the dreaded “Could not connect to simulator” message. So once again I am stuck and unable to link the two applications. Please let me know how to fix this. Thank you.

Steve Haines

Ian, Apoligies for being so persistent with this. After failing to access the Simlink menu icon I did a complete wipe of everything related to Navigraph charts on my Mac. I then re-downloaded the Charts/Simlink installer and installed both into my HD Applications folder. After starting XPlane and then logging into Navigraph Charts I still am unable to see the Simlink icon and still do not have the ability to link XPlane to Nav Charts. I have checked all my System and browser settings repeatedly. Nothing works. If possible could please have Vishal contact me again to figure out why this does not seem to work for me. Thank you for your assistance.

Steve Haines

Guys I fixed it and sharing it with you that might have the same problem, when P3D is running from the upper menu go to: Options/Add on and make sure Navigrapgh simlink is enabled there which if not , tick it and remember it requires simulator to be restart in order to apply your change, Good luck

I have absolutely no idea what this message means or why I received it. What is P3D?

Did what you suggested. Now it works fine. Almost too easy. Kudos!

Hi…,

Welcome.

Excellent, glad to hear it.

Happy flying

Ian

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.