Sign In Button Greyed Put on the Navdata Center

This is what I get each time @stephen

Hi @AidenH ! Sorry to hear that it isn’t working as expected for you.

Are you able to sign into the Charts application, or is the issue the same there?

Kind Regards,

I am able to gain access to Navigraph charts website just not able to get into the other thing which would have a icon in my toolbar in the game and allow me to see my fpl created through thier.

Sorry, I meant the Charts Desktop application which can be downloaded here.

We have a new version of the Hub coming soon as well, that could improve your situation!

Version 1.2.0 has been released! Please try it out.

If you are still not able to click the button, try pressing Tab ↹ to highlight the button and then press Enter ↵.

Everyone, feel free to try it out and see if it improves the situation!

Ian, I am still having the same issues! I have completely uninstalled all previous versions and reinstalled 1.2.0 version.

I tried using the tab button also with no success! Still stuck on the sign in button page.

Really hope you guys can figure this out!


OK I kept playing with it in different browsers and hitting the tab then enter button and it finally let me go to the page where it issues you a code to get signed in. I put the code in and it came up to the normal update page. Unfortunately everything seems to be locked up on that page. when I hover over update or install nothing happens they are completely locked up.

I am using Firefox currently.

Still using 1.2.0 version.

Hopefully you can get this working!


Sorry to hear that you’re still seeing issues!

Are you by any chance using a high setting for the scale in your OS settings?

Using the tab key to navigate should work for any button in the interface, as long as the application has focus!

We have added some additional logging to your account and will investigate further.

I have signed in and out of the Navigraph Hub application a couple of times now thinking that might help. I am always able to sign in and successfully link my Navigraph account. Unfortunately, everything still seems to be locked up within the packages page.

Every single thing is locked up in this page I can’t even scroll up and down!

Thank you so much for investigating further!


Please try this version and let us know if the situation improves!

That was the magic ticket! Thanks for the quick response!

Also thanks for your diligence and hard work, with fixing the problem!

You guys are amazing!

Thank you so much!


Happy to hear that it worked out! We shall push the update to everyone soon.

Thank you for your patience!

Kind Regards,

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.