Several weather layers no longer functional

After the latest update, the following weather layers no longer work for me. It seems to be all the ones with a global color map (but radar works). The starred* layers have numbers showing where the contour lines would be, but no colors. Edit: after un/reinstalling, still nothing in both Mercator and Globe.

Cloud Cover
ISA Temperature*
Jet Streams
MSL Pressure
Conv, High, Mid, Low Cloud Top Level*
Vertical velocity

1 Like

Also notice the same today, some of the weather layers not working, but they did work prior to the latest update.

Hi guys,

We are not able to reproduce. Could you please post some screenshots showing this, where the contour lines are showing but no fill colors?

Which device/app are you on? Do you get the same if you try it on a different device, i.e. use web/desktop instead of iOS/Android, or vice versa.



Hi Guys, I got this issue too but just restarted the Charts App and the issue was fixed.

The weather works great on the mobile app. Does not work on desktop app or web app (same behavior for both)

First pic: radar (works)
Second pic: Tropopause (no colors, but numbers show up)
Third pic: Jet Streams (nothing shows)

Can you try opening the web app in a private browser window to rule out any old cache?

aha. Web app works in chrome incognito.

For me it does not work in the Chart app for windows, but does work in the chrome browser Web app,

Sounds like there is some kind of lingering cache on your computers… Perhaps clear the cache in your browser (For example, Google Chrome on Windows has the Ctrl + F5 shortcut) and reinstall the desktop application?

I am not able to reproduce the issue, unfortunately :sweat_smile:

Kind Regards,

It’s very hit or miss. Some days it works, some not.

I did what you said, I uninstalled the desktop app, clear the cache in Chrome, then reinstalled the desktop app, and still the same result. No icing or turbulence layers showing on the desktop app. It was working fine before the update.

They only work 50% of the time. Some days they all are functional, and some only wind and radar are. I’ve tried reinstalling. No luck. It’s random.

I have exactly the same issue (Charts on Mac). I also tried Charts from Safari, deleting the Safari caché, using private browsing, and even with Firefox, to no avail.

yeah same problem here but only on the windows desktop app because on my iphone and ipad it works 100% in both

I confirn that the iPad Charts app doesn’t have this issue. However, when using Charts with Safari (on the same iPad), its behavior is exactly the same as with Safari and Firefox on Mac.

Summarizing, weather layers have issues on:

  • Charts Desktop on macOS Ventura 13.5.2
  • Charts web on Safari on macOS (also using private browsing and deleting caches)
  • Charts web on Firefox on macOS
  • Charts web on Safari on iPadOS 16.6.1

while they work fine using the Charts for iPad app. I presume that they will also work fine on the iPhone app, but I did not install the Charts app on my iPhone.

Hello everyone! We have been busy the last few days with some team activities, but we have now identified the issue and will release an update that fixes this soon.

In the meantime - switch to light mode before enabling the weather feature! This should fix it.

Apologies for the inconvenience!

Kind Regards,


This should now be fixed in the recently released v8.29.1 version! Please update the desktop app and/or refresh your browser.

The updates will come to the native apps (iOS & Android) as well, but we are waiting for the respective app stores to approve our updates which can take anything from a couple hours to a couple days!

Kind Regards,

1 Like

8.29.1 indeed fixes the issue. Thanks!

1 Like

Thanks for the confirmation!

Thanks so much for the awesome and quick responsiveness and support! Amazing team.

1 Like