RWY import : automatic SID/STAR broken


The feature that you added on my request (thanks again) which automatically allocates an SID or a STAR to imported runways via the API seems to be broken.


Please check it on your end. The last redirect link you sent was:

Parameter Value
planformat EZY
units KGS
navlog 1
etops 0
stepclimbs 1
tlr 1
notams 1
firnot 1
maps detail
contpct 0.05/5
resvrule 30
climb 250/300/78
descent 78/300/250
cruise CI
civalue 4
airline EZS
fltnum 1234
type A320
orig LSGG
dest LEPA
date 28MAR22
deph 17
depm 00
steh 01
stem 00
reg HB-JXI
fin 4721
selcal CKQS
altn_count 0
callsign EZS1234
pax 165
cargo 0.9
cpt vEZY4482
fuelfactor P03
taxiout 13
origrwy 00
destrwy 00
manualrmk /// IDLE FACTOR -3.5 /// PERF FACTOR +2.5 ///
acdata {“name”:“A320-214”,“engines”:“CFM56-5B4/3-TI”,“cat”:“M”,“equip”:“SDE2E3FGHIJ1RWXY”,“transponder”:“LB1”,“pbn”:“PBN/A1B1C1D1O1S2”,“extrarmk”:"PER/C DAT/V OPR/EZS NAV/RNP2 RVR/075 RMK/TCAS ",“maxpax”:“186”,“oew”:93.034964,“mzfw”:137.78875,“mtow”:162.03957,“mlw”:145.50492,“maxfuel”:42.69687554,“hexcode”:“4B1A22”,“per”:“C”,“paxwgt”:194.007,“bagwgt”:0}

Note you’ve sent &origrwy=00&destrwy=00 which obviously isn’t going to work.

Best regards,


Yes indeed this link doesn’t have any runways nor route because it was just a test to check something else :grin:

When I send a link with all the information, it doesn’t work. (The runways and the route get imported as I requested it but without SIDs or STARs, I have to select another runway and then the correct runway for SimBrief to recalculate).

Actually it stopped working one day or two after you implemented it. I’m happy to send you a link where it doesn’t work on my end if you can’t reproduce on yours :slight_smile:

Edit : I retested it, with this link it does as I described. (Actually, for a split second I could see the SIDs and STARs but it gets deleted straight away). UN852 VERSO UL129 LUNIK&steh=01&stem=20&reg=HB-JYJ&fin=4717&selcal=CJAS&altn_count=1&altn_1_id=LEBL&altn_2_id=&altn_3_id=&altn_4_id=&toaltn=&callsign=EZS12AB&pax=156&cargo=0.5&cpt=vEZY4482&fuelfactor=P03&taxiout=13&origrwy=04&destrwy=06L&manualrmk=/// IDLE FACTOR -3.5 /// PERF FACTOR %2b2.4 ///&acdata={“name”:“A319”,“engines”:“CFM56-5B5/3-TI”,“cat”:“M”,“equip”:“SDE2E3FGIJ1RWXY”,“transponder”:“LB1”,“pbn”:“PBN/A1B1C1D1O1S2”,“extrarmk”:"PER/C DAT/V OPR/EZS NAV/RNP2 RVR/075 RMK/TCAS ",“maxpax”:“156”,“oew”:90.609882,“mzfw”:125.66334,“mtow”:149.91416,“mlw”:134.48182,“maxfuel”:42.69687554,“hexcode”:“4B1A3D”,“per”:“C”,“paxwgt”:185.188,“bagwgt”:0}

(Sorry you have to copy paste the full link I can’t get it working as an hyperlink due to the spaces of the route - didn’t bother to add “+” instead of spaces as it works this way).

Hi, it’s because you’re sending a route in the URL. The route you send simply gets inserted into the route field verbatim, and you haven’t included any SID/STAR in it. It’s normal/expected behaviour. :slight_smile:

In a few days maybe I can add a parameter to tell the system to insert SID/STARs into a provided custom route, not sure when yet though.

Best regards,

Ok, I thought that you had already implemented this feature because I was so sure it worked but now I realize that nowhere in this post I talk about a custom route (except in the title of the problem but wasn’t really explicit maybe) and maybe when I tested it I didn’t import a custom route and only sent the runways.

Roger, thanks very much, no worries for the delay !
Good day :slight_smile:

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.