P3D V4.5 will not start after install Simlink

I have a new W10 PC and installed P3D V4.5 and some add-ons. It is running fine. Today I installed Simlink and after installation P3D V4.5 will not launch. It stucks on the banner page. There was no other update etc. Please advice what I should do now.

Update: I have opened the plugin settings and Uninstalled Simlink. The result is that P3D is running again. So the root cause should the Simlink installation

Please advice what I should do to get Simlink re-installed without causing P3D stuck on launch ?

Hi Herman,


  • Disconnect any antivirus and firewall.
  • Uninstall, redownload and install latest Simlink.
  • Restart computer
  • Run Simlink.

If still an issue please try Unable to sign into Simlink - #16 by vishalahir



Please check this also.


Vishal Ahir

Hi Ian,

  • I performed the steps but it did not solve the problem.

  • I also deleted the directory c:\Users\username\AppData\Roaming\Navigraph\Simlink and performed the steps again, same result: it did not solve the problem

  • If I uninstall the simlink plugin for Prepar3D v4 (it is located “C:\Users.…\Documents\Prepar3D v4 Add-ons\Navigraph Simlink” << Could you check if path is ok) ) P3D launches without any problem.

  • in the logs folder there is one dlog file with three lines:

|2023-08-29 20:54:56]|[]|[INFORMATION]|Configuration (Simlink) file or folder is missing. Recreated!|
|[2023-08-29 20:54:57]|[]|[INFORMATION]|OIDC_refresh_tokens_CALL[removed]|
|[2023-08-29 20:56:08]|[]|[INFORMATION]|OIDC_refresh_tokens_CALL[removed]|

.mapping file content:
“files”: [
“C:\Users\…\Documents\Prepar3D v4 Add-ons\Navigraph Simlink\NavigraphSimlink_64.dll”,
“C:\Users\…\Documents\Prepar3D v4 Add-ons\Navigraph Simlink\add-on.xml”
“name”: “Lockheed Martin Prepar3D v4”,
“path”: “C:\Users\…\Documents\Prepar3D v4 Add-ons\Navigraph Simlink”,
“version”: “”

.path file content:
C:\Program Files\Navigraph\Simlink\NavigraphSimlink.exe

I have been a very satisfied user of Navigraph for many years, so I hope you could help me find a solution.

I have compared the add-ons.cfg (in C:\Users.…\AppData\Roaming\Lockheed Martin\Prepar3D v4) on another PC where also P3D V4 and Navigraph Simlink is running and see a remarkable difference:

In the new PC these lines are NOT added to the add-ons.cfg file:
PATH=C:\Users.…\Documents\Prepar3D v4 Add-ons\Navigraph Simlink

In the “another PC” also Navigraph Charts is installed, in the new PC only Simlink is installed !

Hopefully this helps with your analysis


With the great help of Navigraph support team the problem is solved:

The cause was that P3D did not show (somewhere hidden) the confirmation pop-up to run the Simlink Plugins.

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.