OKBK - "No Procedures" in X-Plane (11)

Hi. I have the latest Navigraph cycle installed, but am getting a ‘no procedures’ error when I try to enter the airport into a flight plan. Maybe easiest if I copy this link rather than all the explanation :slight_smile:
Is this fixable via Navigraph? Thank you.

OKBK - “No Procedures”

the ICAO code OKBK doesn´t exist any longer (since February 2023). Kuwait International was changed from OKBK to OKKK. So there are no terminal procedures for OKBK available. The problem isn’t a problem with our data - the problem is the wrong ICAO code in the apt.dat airport file in X-Plane 11.

Here from the latest apt.dat from XP11, which will provided from Laminar Research:

You see very clear, that this code is wrong - this file will be offered by Laminar Research and will not updated with our cycles. So, it´s simple wrong that it´s a Navigraph issue.

You can test it:
Change the code (the red underling codes) to OKKK. Start X-Plane 11 and you will see, that all procedures for OKKK are available immediately.

Hope that helps

Hi. In XP11, none of the a/c I had tried (before posting here) recognised OKKK. I guess I need to check every apt.dat file in XP, there are several for third-party aircraft too (and airport.txt files as well? They too have ‘OKBK’ information), and change the ICAO. I’ll give it another go and post back as to what happens!

Many thanks Richard.

Right, because XP11 has no OKKK in the apt.dat file and therefore you can’t use it. This is an XP11 apt.dat issue. The icao code is outdated, as I have shown you in the screenshot above.


Has worked fine for the main apt.dat file OKKK has procedure - I will check whether I need to change other third-party (aircraft) files too now. Thanks again!

Great! Thanks for the feedback …


What you can do is find the apt.dat file in Global Scenery/Earth Nav , find OKBK and then change it to OKKK. Everything then works as it should, because OKBK still appears in XP12 Global Scenery.