Navigraph Hub will not install

I recently tried to install the Navigraph Hub but the program will not install.

I have disabled my anti-virus software in case that was the issue but it still won’t work. The install bar will either run up to about half then completely stop, or I will get a message saying “This file does not have an app associated with it…”.

I noted that there was an entry in my programs list that allowed me to uninstall it, so I uninstalled the listing for Navigraph Hub, then tried to reinstall the program but it still wont work. I’ve tried a few permutations of this via restarts and fresh installs but nothing seems to work.

I’ve uploaded a screenshot of the error message I am receiving.

Screenshot 2023-05-20 062725

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.



Apologies for the delay in responding.

If you still have the issue, please try again as follows:

  • Disable any antivirus and firewall
  • Download Navigraph Hub
  • Run Navigraph Hub.exe
  • If still not competing, right mouse click on Navigraph Hub.exe and run as Administrator.

Please let us know how you get on.


  • List item

Hello Ian,
Thank you for the reply to my issue. I managed to get the program installed by way of a suggestion I got from a Google search. The .exe had been downloaded to my systems’ default Download folder, a post I found said sometimes programs fail to install from this folder so they advised to move it elsewhere. I moved the NavigraphHub.exe to my Navigraph folder located on my C drive and ran it from there with admin privileges. It worked and installed successfully. I’m still not sure why the file location made such a difference.

Once again thank you for the reply, I do appreciate your help.

Kindest Regards,

Hi Brett,

You are welcome. Glad it is resolved.

Happy flying.


This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.