Navigraph hub thows exception on PC shutdown

On a number of occasions in the last month or so, my PC has shown an exception message when shutting down but the message never showed for long enough to see what it said! (I could not see a pattern and it may well be that that problem has nothing to do with the subject of this report.)
Today, I received the message shown in the attached file.
During this session, I had not used any Navigraph product nor started a flight simulator.

Photo taken with my smartphone…

I’ve also seen this and never got to the bottom of it. I have the hub disabled from startup and only run it when i know there’s an update for something.

But following this, I sometimes leave it running so I see this error on shut down.

Hi, thanks for the feedback! We’ll investigate and see if there is something we can do about this.

Kind Regards,

As a workaround, could you please try quitting the Hub completely by right-clicking the Hub tray icon and selecting Quit?


This is my normal routine. As mentioned, it is just on the odd occasion that you forget to manually close it.

I’m honestly not sure why closing the app doesn’t just quit it though. What is the reason for having it running permanently?

Thanks for your input, I confess that I just didn’t think about it!
I’ll take your advice and only activate it when I want it…
All the best

Did that - it quit without problems…
It really isn’t a big issue - I just thought you ought to know about it!
All the best

Thank you for confirming that this works! That means that we know what the issue is. We will try to fix this as soon as possible when resources become available!

Navigraph Hub should run in the background, as it automatically manages your content.xml file to make sure that Navigraph packages are in the correct order. This avoids issues caused by other utilities that change this file, or manual edits by users who perhaps don’t know exactly what they are doing.

Thus, the default behavior of the Hub is to minimize to the tray and stay in the background! This is becoming quite a popular pattern nowadays too, looking at other applications.

Kind Regards,

Thanks very much for this, Malte.

Cheers for the replies but sorry, no minor application should be required to run always in the background.

For example, my system is used for audio / video work. Flight Sim, although important to me, is probably 2% of my machine usage by time. Do you really think that folks are running their machines only for flight sims and nothing else?

There is absolutely no way that I’m going to have every minor application running in the background.

Btw you said this is common. No. It is not. A small update application based around a game to be forced to run in the background absolutely should not happen.

I have a total of 35 update applications for my various vst plugins and other software. Not one of them is forcing me to run it always in the background.

Aside from that. Yes, the hub does updates. It doesn’t do anything at all once the updates are done. There’s no live interaction with the sim unless there’s an update.

Thanks again but that last reply telling us we should run it always is just not cool at all.

At the very least, it should be an option which can be disabled.

It is common for applications that have functionality that can or should run in the background.
As I mentioned in my last reply, the Hub is designed to keep Navigraph dependencies in the correct order in real-time after they are installed, while remaining in the background.

This feature has been added after numerous support requests where people have used all kinds of tools to change the order of the content.xml, which ultimately results in issues like outdated navigation data, crashes etc. The hub currently prevents this while running, automatically keeping Navigraph packages in order!

I hear that you do not agree with my reasoning - that’s fine.
Perhaps we could make the “soft close” an option, but please be aware that this will result in more support work for us when we start getting questions caused by incorrect content files again, which makes such a solution unattractive to us. We’d rather spend time on developing features than manually solving issues that could have been automatically prevented!

We’ll definitely consider it! I’ll discuss it with the team on Monday!

Kind Regards,

Thanks for the reply. I certainly wouldn’t want to make more support issues. Perhaps just consider it as an option for users who really object to having things running constantly in bg.


1 Like

Hi @AdmiralFunghie

Please try this version of Navigraph Hub.

I have added a setting so that you can change behavior of the app to not run in the background. Right-click the tray icon and deselect “Run in background”. After that the application will quit when you close the window, and the exception should also not happen.

I have also added a fix for the exception also when running it in the background, as I cannot reproduce this problem on my Windows 11 machine I would be very grateful if you could try if it works.

Kind regards,


1 Like

Thanks. This is perfect. :pray:t3:

Is that a confirmation that it works? :slight_smile:

It does now. I had downloaded but not tested and just wanted to reply add say thanks.

Bear in mind my time difference here (+4 gmt).

Now fully tested, All seems to be working as expected.

Thanks again.

Great to hear, thanks for the feedback :slight_smile:

Kind regards,


1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.