Navigraph 8 won't install on PC - installer closes after about 3 seconds

Tried several times now and the installer just disappears after about 3 seconds every time, with no error message.

Rebooted. Nothing else running.

Any ideas?

Same thing if I run as Admin

In TaskMan I killed all the previous Navigraph stuff which was running,.

No difference

Same here, does not install. Windows 10, fails as standard and privileged user.

This is Win10 build 19045.2193

And the installer does close, not hang.

There is no Navigraph detritus in TaskMan after it fails.

Complete bomb.

Every time. as the opning progress bar gtets to about 20%.

And I am logged in as Admin.

Well what do you know. I redownloaded it, producing a file of exactly the same size.

And now it works. Very strange behaviour.

Rebooted, downloaded another copy, installed now…

I though that sounded ridiculous until I decided to try it myself and it actually worked. I redownloaded it like 5 minutes later and it worked this time. Very strange indeed.

Edit: The two files are identical but the first one I downloaded consistently fails, and the second one consistently works. I tried renaming the first file to see if it’s a naming thing and it disappeared. Like, totally. My antivirus is not complaining at all, so I don’t think that’s the cause.

Edit 2: Downloaded a new file again, it’s not working. I renamed it and it does work. Renamed it back and it no longer works. Renamed it to “test.exe” and it works. Deleted the entire name, renamed it to “Navigraph Charts.exe” and it doesn’t work. Something on my system does not like the name “Navigraph Charts.exe”.

Edit 3: Moved the file somewhere else, still named “Navigraph Charts.exe” and it works. So something doesn’t like the name “Navigraph Charts.exe” in my downloads folder. This probably has something to do with that first file that mysteriously vanished.

1 Like

It is werid. And it doesn’t sound like AV or Anti-malware cos the file doesn’t get quarantined.