Moving Maps no longer working on Mac xPlane 11


I’ve been using moving maps for a couple of months or so and just like that ,one day it stopped working. I did recently update to Mac OS Big Sur but I believed I did use the feature after I did that update. The only change I can think of before it stopped working for me was the latest FMS data update.

The problems I face:

  • Takes 5-7 minutes for xPlane 11 to start from the time I click to open.
  • Once up and running, if I try to turn on moving maps, it doesn’t do it any more.
  • the Simlink icon on the menu bar, if I hover my mouse over it, it shows the Mac spinning wheel perpetually.

If I go to Navigraph Sim Link settings and uninstall for Xplane11, then Xplane starts up immediately (15 seconds).

Tried re-updating AIRAC cycle - no luck. No new plugins were installed between when it last worked and stopped working.

Hoping someone can help!



Log.txt (16.7 KB)

Attaching log file. This time it took 5 minutes to open. Without sim-link, it’s usually 20 seconds.

Hello Bevin! Welcome to the new forum.

Thank you for your feedback. We are aware of the issue (see macOS 11 Big Sur: Simlink Hangs, X-Plane Cannot Launch), which indeed does have to do with the MacOS Big Sur update.

We are currently investigating and will advise once we have more information.


1 Like

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.