Moving Map not available on Mac, XP11.50- where do I find SimLink?

I downloaded the NaviGraph Charts app for the Mac, which appears to work well over than no moving map. I read here about SimLink being the connection between Navigraph maps and X-Plane, but when navigating to the SimLinks page it tells me that the app is “bundled” with the charts app for Mac. So- is SimLink an integral part of the charts app for Mac? What I am trying to do is to figure out how to enter the path to X-Plane, but nothing in the Charts app gives me that functionality. Also, I read about a plugin for X-Plane 11 (NavigraphSimlink_64.xpl), but I can’t find this anywhere on my Mac, and it was never available as a part of the Charts app download that I could have moved to the Resources/Plugins folder.

There’s something missing here- either the Charts app for Mac should have SimLink functionality integrated with it (and I can’t see it, and definitely cannot find how to tell it where my X-Plane install is); or I’m missing the SimLink app (which I read here was “bundled” with the Charts app). Thanks for any help, Bruce.

Hi Bruce,

The Charts for macOS download includes Charts for macOS and Simlink.

You should see the two actions required (drag and Install) when you run the installer.

Please let us know how you get on.

Cheers
Ian

Thanks for the quick reply, Ian. It will be tomorrow but yes- I will let you know. Thanks for the clarity on your explanation.

Following up on yesterday’s post here (and thanks again for your quick response yesterday, Ian): I re-ran the Charts app installer on my Mac and saw (as you described) the SimLink installer, which I ran this morning. The SimLink app is now residing in the Applications folder, along with the Charts app. When I try to open the SimLink app, it appears to open but no window is launched to adjust Settings, etc. I also checked my X-Plane 11 / …/Plugins folder but cannot see anything file in there that may have been put there automatically by running the SimLinks app. So, how does Simlink know where my X-Plane install is located? Also, I should add that I cannot show my aircraft location on the Charts app (by clicking the icon within the app, I get the error “Could not connect to simulator”). I’m obviously missing something- is there an additional plugin file that I need to download? I should add this is not a Big Sur GateKeeper issue.

Hi Bruce,

You access Simlink and Plugin Settings etc via Simlink Icon top right macOS Status Bar:

image

Cheers
Ian

Hi Ian, again, thanks for the quick reply. I tried several times to see the icon in the macOS Status Bar, so reinstalled (after deleting the previously installed SimLink app). Interestingly, I couldn’t send the app to the Trash until I restarted as it was reported as being “open”.

When re-installing, I did something differently- I chose not to update to a newer version when prompted by the installer. This time, when running the SimLink app, I did get the SimLink icon on the macOS Status Bar, as well as a window that launched which requested by X-Plane 11 install location, and a button to install into X-Plane at that same location. I’m not sure what is up with the “updated version” of SimLink, but it seems to work OK now. Thanks again for the great support!

Hi Bruce,

Thank you for kind words. Stick with what is working. We are developing a new Simlink for macOS.

Merry Christmas and Happy and Healthy 2021.

Cheers
Ian

Thanks Ian, and hoping that you as well have a Merry Christmas. 2020 must be almost done with us, although I won’t say “done” until after midnight on January 1, 2021!

I have also noted that I get the reminder about updating SimLink when I start X-Plane 11.50, and am choosing to not update. I hope that this might help you with any other Mac users that choose to “update” on the initial install, as that’s what we always automatically do- get the latest and greatest :slight_smile: . Thanks again for all the help.

It is confusing that they ask you to update the Simlink (iMac and Big Sur) with a newer version. After updating you are in trouble. If you are working on a new version of Simlink for Mac (there is no connection with the simulator at the moment) how do you let us know that there is a new version (to prevent confusion, not the way it is communicated now I hope)?

Kind regards,
Henk.

Hi Henk,

Welcome.

When we release the new version we shall advise in this category where you have posted.

Cheers
Ian

A post was split to a new topic: Difficulties running SImlink/Moving Map on macOS Catalina

This topic was automatically closed 5 days after the last reply. New replies are no longer allowed.