G3000 Hardware Usage in MSFS

I’d like to be able to use my new “RealSimGear GNS530” device to interface with all my airplanes, not just the GNS530 planes. I was able to get all the buttons mapped through RealSimGear’s config file system so that the G1000 planes utilize the buttons and knobs, no problem. I am using Navigraph’s G1000 plugin.

For example: “BTN_MENU+=H:AS1000_MFD_MENU_Push” makes my “Menu” button act as a press of the “Menu” button on the G1000’s MFD. Works great. Got the rotary encoders mapped and the COM swap buttons, range, etc.

The problem arises when I try to do the same with the Navigraph G3000 plugin. No matter what I map for the TBM930, for example “BTN_FMS+=H:AS3000_TSC_Horizontal_BottomKnob_Push”, nothing will interface with the G3000 plugin. When I uninstall the Navigraph G3000 plugin, it works just fine, but not with the plugin installed.

I have also tried troubleshooting using SPAD.neXt. When I run the event monitor with the TBM930 and Navigraph’s plugin, none of the button pushes or knob turns on the G3000 show up in the monitor. Is there any way I can utilize my GNS530 unit with Navigraph’s G3000 plugin?

Hello! Welcome to our forum!

To begin with, I am going into this completely without references. I have no experience with the mentioned software, and I do not have the hardware required to do any testing.
All we’ve done is create a plugin through the ways given to us by WT in their avionics, we have not taken any explicit steps to remove hardware support, nor have we overridden things that should interfere with anything like it. It’s an odd situation from the get-go!

Are you saying that none of the events work for the G3000 at all when the plugin is installed, or that you can’t interact with plugin-related functionality?

Kind Regards,

Hi Malte, thanks for the reply over the holidays!! The functionality of any G3000 button or knob is affected. Unless I remove the plugin and use the default aircraft, I’m unable to get my hardware to tell the G3000, “H:AS3000_TSC_Horizontal_BottomKnob_Small_INC” for example. This should tell the sim to turn the knob for map range on the GTC but it doesn’t seem to do anything with Navigraph’s plugin installed. And as I said, SPAD.neXt doesn’t “see” any events at all when I click on the knobs and buttons in the simulator, even though when I click them they work just fine.

This is essentially the same thing as what Mobiflight users do with their home-built knobs and switches and whatnot, but instead of using Mobiflight to change the hvars I’m changing code in a config file. I have been using https://hubhop.mobiflight.com/presets/ to find the G3000 code.

I have not tried monitoring with SPAD.neXt with the default aircraft yet, I believe that’ll be my next step. I will also try unplugging all my peripherals except the GNS530 unit, restarting the computer, and probably messing with the command mapping files some more.


Update: I have figured out the root of the problem. I still had Working Title’s G3000 plugin installed in MSFS. Since their code was pushed with the AAU1 update, I uninstalled that, rebooted, reinstalled the Navigraph plugin and everything is now working as it should. My only problem now is that I can’t get a long-press action to work with the top knob on the GTC but that’s minor. It’s probably related to RealSimGear’s own limitations rather than anything to do with Navigraph.



1 Like

Thank you for the interesting insights into this process! Sounds like a fun project for sure, even if it sounds like there is quite some potential for frustration when things don’t work :sweat_smile: It’s always cooler to have hardware involved!

Thank you for sharing your solution with us so future visitors can benefit from your research. It’s much appreciated!

Kind Regards,