FMS Data Manager MacOS Ventura 13.0 Crashing

When I try to launch FMS Data Manager in MacOS Ventura 13.0 an error message appears and says the application cannot be opened. Then my system is completely unresponsive and I have to do a hard reboot to use my computer again. I just reinstalled FMS Data manager from the website and it still will not open and freezes the operating system.

I have the same error and same problem on my Mac with Mac OS 13. It was working nicely on Mac OS 12.6.1.

Hi Team,

I just upgraded to the latest OS Ventura V 13.0. I ran FMS Data Manager V for Mac without error.

Try checking you have same latest versions. I shall ask our Mac team if they have any issues, or suggestions.


Any ideas on how you can check the version if you can’t launch it? The only thing I can think of was to download it again from your website and try to install it.

Also, not sure if this matters but I am using an M1 Mac

Hi Ian, I’ve just downloaded the latest release from Navigraph and still says that the app FMS Data Manager cannot be downloaded, you click OK the menu closes and after a few seconds the computer freezes and you have to force a restart. My Mac has an Intel I5.

1 Like

Update… Looks like I had 2 versions installed on my computer and didn’t realize it. I was launching the old one. I have since deleted the old one and the new one works! Problem fixed.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.