FlyByWire A320neo tablet Charts says I'm on Demo, but I have Ultimate subscription

I’m having a weird issue on my FlyByWire A320neo tablet. If I try to load a chart in it, it says I require the Ultimate subscription, and that I’m just running a Demo, even though I do have the Ultimate subscription.

I double checked to see if I was logged on the correct account on the Navigraph Charts software, and everything seems to be in order. Except that bug, that is.

I also tried reinstalling the aircraft, on different versions, but this problem persists both on Experimental and Development versions.

Any idea what might be wrong? Thanks for the attention.


On a side note, off topic, but probably relevant. For some reason I cannot Import Simbrief Data on the tablet. My flight plan is stuck on the last flight I had, and it won’t change no matter what I do.

Hi,
are you sure, that you logged in with your correct account? Because with this account (CmteClaus) you don’t have/had any subscription.

So please check your account again.

Cheers
Richard

(OP here)

Yes, I am sure I was on the correct account. I was logged on the correct account on the website, SimLink, Chart and the Navdata Center.

For some reason here on the forums it was logged on another account I tried to make when I didn’t remember my original account (this one) details.

Did you find a solution to your problem? I recently upgraded to an Ultimate Subscription but I’m unable to get charts in the current development version (127787b) of the FBW A32NX. I have always seen the Demo screen, but now that I have an Ultimate Subscription, I still can’t get the feature to work.

What is required to get this feature to work? I’ve scanned the QR code and I also have Navigraph Charts running and logged in.