Fenix FMC misses sids & stars + some rwys

I started with the Fenix some days ago. I miss the STARS & SIDS in the flight computer. I have latest AIRAC in Simbrief and i updated the Fenix with Navigraph tool. I also miss runways (even on Amsterdam).
I suspect the installer to mis-installed the files where they cant be read and since the installer is from navigraph i come here :slight_smile:

I noticed that the installer says that it is installed “outside of flightsimulator” (see screenshot/upperline), which is a bit strange maybe.

Hoping this issue can be solved soon i await if someone knows a solution. Fenix does not know as for yet. Tia!

it looks you have an issue wjth the Fenix installation itself. I would recommend to re-install the Fenix first and look, if you then have all runways and/or terminal procedures.

After that, when you are sure, that all is ok initially, start the Navigraph Navdata Center again and try to make the update again to the latest cycle.

But again, make sure that all is ok after you have re-installed the Fenix. Possible you can make a screenshot before/after … Thank you!


Hi Richard,

Thanks for the quick reply. Helpdesk from Fenix told me the same so i already did what you suggest, without good result. Could there be an issue with placement of files maybe. I have FS2020 once bought from Microsoft Store. Maybe it has different folder structure than a Steam version?

Yes the steucture is different but Fenix is independet of this different structures, therefore the “outside of MSFS” tab in the Navigraph Navdata Center.

It must be an other issue, therefore my recommendation. Try to un-install the Fenix, reboot your PC and start the Fenix installation again. When it’s done, look that all is ok now (also when the AIRAC is outdated). When all this is ok now, after then try to update the AIRAC cycle.


Ok well i did that once again. Tested before AIRAC update and after and still i dont get all runways and sids and stars.

I think i should see others if they were there, when i push the arrows, not? So anooyingly odd :frowning: to be stuck like this on a nice plane.

Btw my pc is only 1 month old so in good shape an basically is only for flightsims.

Hereby a screen of the rwys i can select for Amsterdam.

… and when you go up (with the arrow keys) you don’t see any more runways?

Sorry, thats very strange because either you have data or not but its not possible that you have only a few data.


No i tried all directions.

… and that happens also, after the init setup, without an AIRAC update?


Yes i tested without any update first :sweat:

Hm, sorry no idea … when this happens before also, then its more a installation issue on your system but again, the strange thing for me is: it’s one database and not several files. Means there is only one possible state: working or not working, full or empty but nothing between.

Sorry that we can’t help more

Well maybe some of the data on rwys and sids, stars is actually in the basic installation of Fenix then (i would say).

As for the installation issue. I think the installer is the installer. I cannot change a dime on that.

Well lets hope Fenix finds the time to help me further.

Thanks for trying to help me anyway on short notice.

No, the database for the default setup is also a fully database. It’s only outdated but specially your example EHAM has all runways included.

I will try to install it from the scratch to get the default/initial database. After that I will try it too …

Strange is, that you see the arrow up on the FMS that means the FMS has a follow up page, so it should be possible to switch when you press the arrow up key on the FMS …

Strange but I will try it too

OK that would be nice of you. In meantime i reinstall FS today. Who knows it was some addon that messed things up.

With the arrows i did see another page btw, but it just showed some runways and not the next rows with the other SIDS&STARS you would expect to see.

So, tested with the default dataset which will be delivered with the Fenix setup. No problems, all runways are included and selectable

Page 1:

Page 2:

Page 3:

You see on the last screenshot the “END”, that means no other pages available. That´s missing on your first picture - you see only the arrow above, so I´m pretty, pretty sure that you have any other issue or a simple handling issue. Also in your database are more than one page … because when it would only one, you would see the “END” sign and that´s not the case.

Sorry, something is wrong on your core system and/or your Fenix installation - or you it´s a simple handling issue, I don´t know but I´m 100% sure now, that all is working as expected - with the default/outdated AIRAC and also with the newest AIRAC cycle 2304.



Well i am afraid i must admit i must have never thought about pushing the UP key to see what is next. I was automatically thinking in pushing right and down as i expected that to be NEXT for some reason. UP does not feel that natural i guess. And also the left/right arrows in upperright corner of FMC put on wrong idea.

Long story short i today re-installed for no reason and i thank you for analysing what went wrong! I appreciate it!


Thanks for your feedback - no problem, I thought its more a simple user issue, therefore the detailed screenshots.

I also learn every day anything new, so it’s absolutely human. Thanks again for your time, your patience …

Have a nice weekend and enjoy the Fenix A320 with a full worldwide and most realistic database :slight_smile:


Thanks again and have a great weekend too! :grinning:

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.