Data Manager interface not showing up

Fresh installed Data Manager under default path in windows 10.
The icon shows up in the tray, but when click on “show interface” nothing shows up on screen.
In task Manager, there is only “Navigraph FMS download agent”



Lets start afresh.

Please disable any Antivirus and firewall.

Please use Windows to uninstall FMS Data Manager. Specifically use FAQ - Charts desktop installer fails immediately

If they exist, please delete folders:
c:\ProgramData\Navigraph\FMSClient and c:\Program Files (x86)\Navigraph\FMS Data Manager.

Please download and install latest FMS Data Manager .

Please let us know how you get on.


DId every thing as you said.
Still the same.
click on “Show Interface”, the mouse pointer wheel spins for less than a second, then nothing.

Same issue here. The busy cursor spins for a bit, then nothing. The data agent starts in the background, chewing up a fair amount of resources doing something which is not bringing the GUI up on my screen.

Also tried the above fix to no avail.

Hi Team,

Please check you don’t have Antivirus , Firewall or other security software which might be blocking FMS Data Manager working. Any network restrictions?

Please upload latest log from c:\ProgramData\Navigraph\FMSClient\logs


Only Avast. Tried with it turned off but no improvement. Peculiarly nothing in the logs folder. In fact, the logs folder isn’t there - just the config file.

A new instance of the agent starts on every attempt, using 25% of the CPU.

I’d say it gets stuck doing something while starting.

I did try the MSFS 2020 beta navdata update. Any chance that may be related?

It’s working now. I haven’t done anything, just decided to try anew. It started, getting me to the login screen and then the update screen as per usual.


Hi Fred,

Thanks for the update. Glad it is resolved. These pesky computers… :wink:

Happy flying.


This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.