CTDs with Navigraph installed...ok without

Ok, I’ll try to keep this detailed but not too long winded. Luckily, I’ve been one of the seemingly few that have been happy with MSFS2020. I haven’t suffered but one consistent CTD that I would get at EIDW, whether it be defauly scenery or the payware addon I had bought. So, I subscribed to Navigraph two days ago and since then, its been random CTDs everywhere I have flown. Whether it be with FBW’s A320, WT’s CJ4 and even default aircraft. I really don’t know what to try. The only thing that has cured the CTDs is to uninstall all things Navigraph. Seems this is an odd case and I don’t fault you guys in the least. I just want to figure out how to fix without having to unsubscribe to the service. Odd thing, I don’t get a CTD at Dublin now even after uninstalling Navigraph.

thanks for the detailed report - we will find a way that you must not unsubscribe … possible in the next year :wink: … but we will find a way …

First to verify:

  1. You are using Navigraph Navdata client beta 19 - correct?
  2. You are using the current AIRAC 2014 revision 1 - correct?

Both are important :slight_smile:

Ok, as a first try, when you can both question above answer with YES:

  1. close the sim
  2. open the Navigraph Navdata client and remove the AIRAC cycle
  3. depending which version you have installed (Steam or Marketplace), go into the following folder
    Steam-version: %appData%\Microsoft Flight Simulator
    Marketplace version: %localAppData%\Packages\Microsoft.FlightSimulator_8wekyb3d8bbwe\LocalCache
  4. delete (yes, delete) the content.xml file - you don´t need to backup it because the sim re-create it automatically
  5. start the sim
  6. close the sim
  7. open the Navigraph Navdata client
  8. install the AIRAC
  9. start the sim and try it again …

It is really important, that you go thru these process step by step. It´s currently the only way, that we are after that on the same level for further support, if needed.

Ah one other thing, after all the steps above. Try the same without any mods (CJ4 or A320) and look what happened. Thank you!


PS: Happy New Year, if we hear/read us again just in 2021 :wink:

Same result, default aircraft, default airport. CTD as soon as I hit “FLY NOW” on the runway. Followed the instructions to a T.

All right - I´m pretty sure, that this will solve your CTD … because this CTD with “Fly now” was an issue from one of the past revisions, which are still fixed.

Thank you,

Your solution did NOT work. I’ve never had the “FLY NOW” or any CTD problems until installing the AIRAC from Navigraph. One thing I did just think of, I have several payware airports installed and have disabled some of the default airports in the content manager. Does the AIRAC data need those default airports enabled to work correctly? I was just pondering this thought and hope maybe that might be it.

Please upload your content.xml file here, that I can check something because it must be something wrong on your system.

As you see, there are no other CTD reports, so its not a general issue.

Thanks for the file

Content.xml (7.4 KB)

There is my newly re-generated xml file. I’ve tried your above steps 2-3 times and same CTD every time. As I said, it seems to be a unique problem. Guessing a scenery issue…maybe the next step would be to remove all NON payware scenery from my community folder perhaps?

Thanks for that … Looks good so far.
What I would try is, move the whole Community folder outside in any backup folder.

Delete the content.xml file, run the sim, close the sim and install the AIRAC again.
The start the sim again and try a typical CTD situation (if you have one).

I also assume its a bad/corrupt file in the community folder.

Sorry for the effort now but its really a little bit strange. We read us next year :slight_smile:

Cheers & Happy New Year

Sadly, I have completely cleared my community folder and repeated the initial steps given above. While without Navigraph, it loads just fine. As soon as I load back up with the AIRAC installed and hit “FLY NOW”…CTD. Seems not to be a problem within the community folder. So frustrating and thank you so far for you help even though we haven’t gotten anywhere.

It’s so odd. It’s the data itself. There is something in my sim that doesn’t want to play nice with it. I was able to complete a flight with updated airac in SimBrief and the plan loaded into Charts following along via Simlink and also my SimToolKit Pro was running alongside it all. Just no AIRAC installed into FS. The charts software is SO GOOD!

I’m having a similar issue, I’ve been getting mid flight CTDs. I haven’t been able to complete a flight all day long.

It just seems to randomly happen mid flight and I haven’t experienced any issues like this before.

I’ve tried not using charts and I’ve tried using charts on a separate device, I’m thinking about turning off simlink to see if that helps.

It’s frustrating to purchase something that was supposed to help but instead it has made my sim experience terrible.

This topic was automatically closed after 2 days. New replies are no longer allowed.