Could not connection to simulator


I have the problem “Could not connection to simulator” with Simlink after i did a reinstall of FSX.

I have uninstalled Simlink and FSX a couple of times but the problem is not fixed with that.

When i run FSX and Simlink it doesn’t see the FSX running.

See the attachment

Regards, Gerrit

Hi Gerrit,

Please use Windows to uninstall Simlink:

If they exist delete directories
c:\Users\username\AppData\Roaming\Navigraph\Simlink and c:\Program Files\Navigraph\Simlink.

Then download and install Simlink .

If you are still experiencing problems please post screenshots of Simlink Status and Simlink Plugin Settings pages using Guide to posting Screenshots

Please let us know how you get on.


Hi Ian,

At c: \ Users \ username \ AppData \ Roaming \ Navigraph \ Simlink
there I also deleted it
It is not installed on c: \ Program Files \ Navigraph \ Simlink.
maybe that’s the problem.

Cheers Gerrit

Hi Gerrit,

I did say “If they exist”, as a precaution. Windows uninstall should remove folder c:\Program Files\Navigraph\Simlink.


Hi Ian,

i deleted everything in all directories and reinstalled as you described i keep getting the same message
Could not connection to simulator on the cards
reinstallation does not help


I have been having the same issue…
Reinstalled as described…
Still no joy.
Was working before a fsxse reinstall.
I’m at a loss!

Hi Brad,


Best in Simlink Plugin Settings to uninstall Simlink plugin from each FS, then completely uninstall Simlink using Windows Programs and Features

If they exist delete directories
c:\Users\username\AppData\Roaming\Navigraph\Simlink and c:\Program Files\Navigraph\Simlink

Then download and install latest Simlink using the default prompted locations.

If still an issue, please posts a screenshot of Simlink Status page using Posting Guide - Uploading Screenshots


After reinstall of windows its working again. So the solution is reinstalling windows when everything else doesn’t work.

Hi again.
Still no luck.

simlink_2021-11-05.dlog (5.2 KB)


So, after giving up on simlink… Im now at the point I really need it to work.
I have revisited all the advice… plugin still doesnt see the sim…
Please help…
What am I doing wrong !!