Charts 8 In-Game Panel Beta Testing

Just took off from LESO using the MK-STUDIOS payware scenery for that airport and tonight, I didn’t see any stuttering. Not even in VR mode. So I’m not sure if this could be related to what airport you’re using.

If/when I see the stuttering next time, I’ll do some testing as suggested if I find the time for it.

Its very subtle infact up at fl350 Friday there was no srutters yet on the ground stutters arrived, i may add not looking ahead but to any side window.
It is any airport for me regardless.

Learned earlier the stutters are not srutters but skips/jumps/hops and are in perfect synchronisation with the moving map plane icon.

It looks like the plane icon on the map is linked to the ground outside the plane and its this whats causing the jumps/skips/jumps outside, as the plane skips to its next point on the map so does the earth skip in the same jump/skip/hopping motion.

So if you disable ”follow mode”, the issue is less noticeable?


Another question unrelated to this, when having enough charts pinned to bring up the horizontal scrollbar, I fail to “grab” that scrollbar with the mouse to drag it right to see all charts.

The only way I’ve found to see any charts to the far right is to make the complete Navigraph window bigger.

Is there a way to use the scrollbar in VR I’m yet to discover?

Hi Richard,

Check you have the latest Charts version.

Can you use the keyboard left and right arrows in VR?

Please see Pinned chart scrolling - #9 by Ian


Thanks Ian, will try using the left and right arrow keys on the keyboard next time.

As for using the latest version, probably not if it was updated since this thread was started. I downloaded this beta from the link in the first post and wasn’t aware there’s been any updates after that.

Yes V8.1 is latest and was released 5 Dec 22.


Got it, will make sure to download it.

What is the easiest way for us beta testers to find out when a new build is available?

1 Like

could you please update to use the new layout and include vfr map also? i know there is also, but lot of existing aircrafts using the old one.

1 Like

I’m a bit curious - Why are you using that specific (chartspanel) URL? It is only intended for use in our own in-game panel.

This whole thread is precisely about beta testing the new app in the panel before publishing it. Publishing means pushing the new app to the chartspanel URL.

1 Like

There are two pieces of software in interaction here. As for the app itself, you always have the latest version as it is fetched via the web. You can see the version in the Settings page in the app (cogwheel icon in bottom left). It is currently at 8.15.

The other piece of software is the panel framework, the part that sits in your community folder. It is basically the frame around he app, and it also holds most of the interactions between the sim and the panel, such as the import of flight plan on app start. It is now this downloadable ZIP in this thread, but when released it will appear in the Navdata Center app, and there it will be more clearly showing when an update is needed. So keeping that up-to-date is just one click of an “update” button. It is currently at version 8.1.



Thanks Stephen.

I understand updating of the part on my side will be easy once it’s not in beta anymore. My question here was if there’s a simple way to learn when a new beta build has been released now when it’s still in beta.

No big deal though, I simply downloaded the zip file again. Meaning I’m now on the latest version.

1 Like

OK, here are my two cents about the stutter issue:

  • Using the last ¿? version of the beta (8.1) downloaded from the Zip (first post in this thread) and installed in community
  • System specs: i7 11700, RTX360Ti, 32 Gb RAM
  • Flying VR (Reverb G2)
  • Aircraft: Fenix A320
  • Other mods: GSX, Aerosoft simple traffic, many custom airports

I have flown with this beta since day one, usually without stutters. However, since a couple of days ago, I get stutters since taxiing and during all the flight.
I use the shiftZstats FPS counter, and the FPS do not drop (at least much) during the stutters.
Stutters happen all the flight (taxiing, cruise…). So it should be no Simconnect issue or GSX issue (GSX is supposed to be idle during flight. EDIT: I tried also closing the GSX app during flight, and stutters persist when I open your panel).
Things I tried:

  • If I fold the Navigraph beta panel (button “-”) stutters stop. If I unfold it, stutters reappear
  • If I unload from the Navigraph panel the current flight plan, stutters stop. I can use the map, zoom in and out, etc. and everything is smooth.
  • If I reload the flight plan, stutters start again.
  • If I load a short fly plan from the list (from the history flights), stutters are less evident.

So it seems to be related with how your software manages the flight plan, and the problem gets worse with longer flights (more waypoints).
Flight plans tried with heavy stutters: LEBL - EGCC; EGCC - GCRR
Short flight plans tried with less apparent stutters: LEBL - LEPP, LEPP-LEMD, etc.
This beta is amazing, I just love it, but there must be something in your end which you could do to prevent this issue. I hope you can find the culprit and address it!

because some aircrafts tablets are using it and they are reffering to the old one. its ok if you will update it at the end of the beta, thanks!
im barely using the panel, instead of that i would like to use it on my aircrafts tablet.

Where is the World Map option in v8?
I cant find it and for me its very important



1 Like

Still the same regardless im afraid.

Hey Ian,

Still same thing using the latest version. Where I’m not able to use the scrollbar.

Tried using the arrow keys like you suggested and that works fine but is somewhat cumbersome when you’re in VR. Plus it also moves your view left and right in MSFS.

So hopefully, you can find a way to address this and allow the scrollbar to be used as intended.

Are you on version 8.15 ?
Im abke to move the bar with the arrow keys but like you say it also moves msfs at the same time.

Unless the zip file once again was updated without notice the last day or two, I’m on 8.15 if that is the most recent version. A bit hard to do proper beta testing if you’re not notified when a new build has been made available.

Back to the issue, you say you can use the arrow keys but can you use the mouse to drag the scrollbar?