Can't log in Navigraph Hub


I have a connection problem with navigraph hub, when I ask for Log In, it opens a web page on the default browser and asks me to connect. Once connected, it sends me back to a page which tells me that the connection has been successful. But when I switch to the Navigraph Hub app, I see a dark blue page, then the app returns to the white page with ‘login’ in front.

I tried:

  • open the login page on Firefox, Chrome, Safari,
  • open with the qr code and my phone
  • open the page with another PC on another network
  • change network on my main PC
  • cut all firewalls and DNS hole
  • checked time with (Good synch)
  • uninstall navigraph with control panel
  • remove all navigraphHub.exe from my Download folder
  • uninstall Simlink and Charts, which manages to connect properly by the way
  • reboot my PC at each step, after each installation and each network change
  • Check whether Usrconf.opt files were present after each uninstallation.

I’m running out of ideas, I’ve looked at forun and google but all the solutions I’ve tried haven’t worked.

The Login page keeps coming back ;(

Hi ScheduledDestinatio1,

Thanks for the effort in trying to solve this on your own, you seem to have tried all the usual ways :slight_smile:
Please run this version of Navigraph Hub, it will most likely not solve the problem but it will record some debug information that we can access in our end to be able to identify what is going wrong.

Kind regards,


Hi !

I’ve just launched the EXE you sent me, taking care to uninstall my old navigraph hub.
The first launch was scanned by my antivirus, but I deactivated it and relaunched navigraph.

This time the login page doesn’t come back, but instead a dark blue page with no text appears.

Note that I’ve just gone back to, but this time it’s telling me I’m 0.2 seconds behind…
I don’t know if it’s enough to interfere, but I’m going to start looking at solutions to synchronize my time correctly.

Hi again,

It is a network error with the Hub not being able to connect to one of our servers. I don’t have logs from the first attempt you did when you were being redirected to the login screen, but I assume that it was because it could not reach our service that handles the account. Now it cannot instead reach the service which provides the packages to download :slight_smile:

Could you please verify that there is not firewalls blocking outgoing connections from Navigraph Hub?

Kind regards,


I tried again on two different networks:

  • Direct from my ISP router
  • In connection sharing with my smartphone.

In both cases, my Windows firewall was down.
In normal conditions, I’m using an Opnsense DIY router, but the problem doesn’t seem to be coming from there, since the other networks aren’t working either :smiley:

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.