Hub not signing in

Hi Guys,
I cannot log into the Hub. I click Sign in and the new tap to log in with username and password open. I fill in my login credentials and iam in. After I approve the link of my account and get following message: “Navigraph Hub was successfully linked with your Navigraph account. You can now close this window.” After a few seconds I am back on the “Sign In” page in the Hub. Tried it a few times, also I checked topics similar to my problem and tried some things:

  • Different Browser: Firefox, Chrome, Edge
    -Sync Clock
    -Deinstallation of all Navigraph products and delete temp folders
    -Administrator Privileges
    Thanks for help

Hello! Welcome to our forum!

That does indeed sound like a timing issue. You mention that you have already checked this, but to be completely sure, could you go to and take a screenshot of the result?

Kind Regards,

Hi Malte,

unfortunately in German but it says that my clock has exactly the right time.

That’s great! Let’s also take a look at your logs. Please follow these steps:

  1. Press Win + R
  2. Type %appdata%/navigraph-hub/logs and press enter
  3. In the Explorer window that opens, locate the main.log file
  4. Upload this file to your next post

main.log (4.5 KB)
here you go

Did you recently change your email? The email used by your forum account does not align with the one that I see used from within Navigraph Hub. If you did, have you confirmed your new email address?

Yes, I changed it yesterday (I read something about that possibly helping). The email has been confirmed, but the problem was not solved.

Thank you for the confirmation! I am at a loss, but I will ask the team to take a look as soon as possible!

After you press sign in, there should be a QR code and a code made up of a bunch of letters and digits. Could you take a screenshot of this screen and upload it here?

here the QR-Code

Thanks! And did you attempt to sign in after showing this too?
And did you get signed out again?

I attempted to sign in using a QR code on my phone and a different browser. I also tried signing in directly through Google login and manually entering my login credentials. Have tried every possible method of signing in.

I believe you! I just wanted to make sure that you have tried using that specific QR code so that we can attempt to trace the requests on our servers!

Thank you for confirming.

Hi @890400

Can you please try out this version?

Kind regards,


Same problem after log in and approval but now even the sign in button is gone.

Yes, but now I got some debug info on my side :slight_smile:

Navigraph Hub gets an unexpected error (which is obviously currently handled poorly) when opening the file M:\WpSystem\S-1-5-21-3155462289-2520458828-1761853474-1001\AppData\Local\Packages\Community\pmdg-aircraft-737\Config\NavData\cycle.json on your system. Not sure what is the cause but deleting the file should solve the problem. Navigraph Hub with automatically replace it with a new one anyway.

Kind regards,


What about SIMLINK… it’s constantly disconnecting…

now it works perfectly. Thank you for your help!

Glad we could solve it finally, thank you for the patience :slight_smile:

Kind regards,


This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.