App freezes and crashes

After the new charts update I have issues using it on my ipad. I have latest ipad and latest iOS. When I select different pinned charts the app becomes unresponsive very quickly. Most of the time it crashes after all. Tried on another ipad, same story. This new chart update almost unusable for me on ios.
Another issue I cannot unpin charts. They just stuck till I select new flight.

Cannot help with your first issue but as far as unpinning charts, have you unsynched with current flight? Having done that press the orange edit button in the lower right hand corner. Thereafter you should be able to unpin unwanted charts.

Hello. Same here with new IPad Air and latest iOS Version.

1 Like

Same here as well, pretty bad.

Hi all,

”Same here” isn’t very helpful. This thread is from November last year. There have been maybe 10 app revisions since then…

Could you be more specific about what the issue is? What are the steps to reproduce which issue? Which app version are you on (check Settings)?



Hi, I’m on 8.22.0. After the update the app hangs up completely all the time. Never happened in the previous versions which has been very stable.
It often connected to selecting new flights, or adding new charts to a flight.
Everything freezes and even after a restart its still frozen.
It’s really bad actually.

Best regards

1 Like

Yikes, didn’t see the date. The app freezes a lot when trying to load a flight plan and just do anything. Even after force quitting the app hangs and freezes. Never had that happen before the most recent update.

1 Like

Yep, this pierce of software is absolutely rubbish right now - I’m getting fed up with the app freezing every time I change something like reviewing the approach charts. This isn’t good enough when we pay good money to subscribe to get a service that’s not being delivered - may as well cancel it.


It shouldn’t be like that of course. We are not able to reproduce this crashing/freezing behaviour on our end. It must be something specific to the specific flights you are loading. I have added extended logging on your accounts, please now restart the app and try again. Report here when it has frozen or crashed again, then we should have data to investigate.

Sorry for the issues.



Stephen, I don’t believe it’s specific to this flight that I’m running now because it’s been happening for some time now, as in at least the last 2-3 weeks but it is worse today than previously. What I have noticed lately, is the delay when selecting any item - so maybe the delay is really, really, really long but either way, it’s annoying. One other things I notice - when I selected the App, ‘offline’ appears for a very brief moment. So, right noe, I’ve closed down and re-opended the app, selected APP and nothing - try again and then it appears, so very laggy. Not sure if any of this helps.

Ok, I’m back into the sim and on the iPad I’m trying to delete the previous flight - The ‘delete all flights?’ dialogue box is just sitting on the screen with the wagon wheel spinning - nothing is happening - even after several minutes. This should be instant. This not an iPad problem, this is a program problem. So once again, I have to shut the app, and reload.


Please see Deleting flights -> Endless "processing" - #4 by stephen


Hello @speedbird144 and others in this thread! We managed to reproduce and subsequently issue a fix for an issue that would cause the app to freeze and/or crash. While it is not guaranteed that the issue was OPs, please have another look at the latest update 8.23.1!

For more information, see this thread:

Ok thanks for info. I will try it out right away

3 posts were split to a new topic: CTD when opening iPad app, version 8.23.1

The app still freezes for me. I reinstalled and it still freezes. Latest version. I cannot even use it anymore. I have to use charts in the sim. I tried it on 3 different iPads and still have same issue.

We are not able to reproduce this, and we do not get any crash reports from Apple. We can see the amount of crashes though, and it is rapidly decreasing since the last update. Your issue is likely to be caused by something else, apologies for the inconvenience!

Please see this thread for more information, and feel free to follow the suggestion: