AIRAC Cycle 2112 rev. 2 crashing to desktop

Since the latest update the sim crashes to desktop as soon as I try to load in to any plane. The loading bar gets about three quarters of the way through before it crashes. If I remove the AIRAC cycle the sim works fine with the default cycle provided by Asobo.

I’m using Navdata Center version 1.0.3 and I’ve already tried removing and reinstalling it, but it did not help.



Do you have any MSFS addons aside from Navigraph, especially scenery?

I suggest you implement reorganisation as per FAQ - Scenery-File re-organisation / initialization.


That didn’t work. It still crashes to desktop. It’s the only add-on that seems to be causing issues. I even have the Navigraph in-game panel add-on and it works fine.

Please upload your content.xml file.


Content.xml (7.3 KB)

Thanks, it looks good. You don’t use any addon linker or similar else?

Also we have none information, when such uncommon CTD happens. It must be anything on your system, because we don’t have any other report of such CTD. You dind no here, nor in orher forums. Sorry, but in this case, I would try a re-install of the sim.

I don’t see any other chance … sorry


Well crap. Now It won’t load even with all add-ons disabled. Still looking.

There is any issue, for sure, because its uncommon. The bad thing is, we or also ou don’t see where and what that you can react.

Possible antivirus or the OS in game protectiin block files/file types. Have you tried to disable firewall, defender, antivirus, …

Possible that is the reason …


I think I got it. I deleted my rolling cache and rebuilt it. It loaded into a flight with no issues. Then I quit and re-enabled all add-ons including the latest AIRAC cycle. Started the sim again and loaded into a plane with no issues again.


Thanks anyway for the help.

1 Like

Great to read that and very good analyzes, good job. Thanks for sharing your solution. The rolling cache tip is great. Never thought about this … every day is a new day, also after 20 years in this business …

Glad that it is fixed! Happy flying!

Take care

TLDR: Reverting the Nvidia driver was the only way to resolve this issue for me.

Just to put my experience out there for any other user that comes across this issue. Deleting the rolling cache after removing all items from the community folder and removing navigraph data via the data center app seemed to work initially. But upon a further restart, the issue popped back up.

I eventually came across a thread in the steam community discussion page that suggested the latest 497.09 Nvidia driver was the culprit. I reverted back to the previous driver and all is normal with MSFS… For now. One thing I never did try was dx12 with the latest driver. Something to test another day I suppose.

Yes. I spoke too soon yesterday. After deleting the rolling cache I was able to perform two successful flights, but on the third I got the CTD again.

I also discovered the thread over on MSFS forums about reverting the NVIDIA driver and that did the trick for me. No more CTD.

Thanks for the updates @ND8472 and also @Xaqsi19


This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.