Administrator Privileges Required

I have build a new PC / WIN10 and installed my EFB2 client on it. I have the Downloader running on the simulator PC. When I try to download a flightplan file to the EFB2 Routes directory I get the following error:
Administrative privileges are required to save the following files: Z:\User|Gigabyte2\Documents\AivlaSoft\EFB2\Client\Routes.
Click "Yes"in the following alert window to export these files.
Any help on this issue would be appreciated
Juergen Mader

What happens when you click on “Yes”? You should see a Windows pop-up asking to run as administrator. If not, what do you see? Any error messages?

If you don’t see it, maybe that means you don’t have administrator privileges on your Windows user account. Not sure what to suggest in this case, other than to change your Windows preferences or account settings.

When this error occurs, I have 2 options:

  1. Continue
  2. Skip These Files
    If I press “Continue” another dialog comes up:
    1 file could not be saved;
    file path and file name;
    An unknown error occurred
    If I press “Skip These Files” another dialog comes up:
    1 file could not be saved;
    file path and file name;
    -Insufficient permissions
    Thanks for reply
    Juergen Mader

In your initial post, the directory you quoted was:

The “User|Gigabyte2” part seems a little strange, is that a typo perhaps? Not sure if it’s related to the issue you’re having.

Can you do the following for me:

  1. Run the SimBrief Downloader and try to export the file as usual so that you experience the error again.
  2. Click continue so that you see the error message which says “1 file could not be saved…”
  3. Then, on your PC, browse to the following directory (copy/paste this path into a Windows explorer window): %appdata%\SimBrief Downloader
  4. There should be a file in there called “console.log”. Please open it in notepad or another text program and copy/paste the contents here for me to see.


I browsed to the directory where the EFB2 flight plans are stored, so it should be correct. The “Gigabyte2” stems from the initial Windows10 setup and should really be named “Juergen” (but I don’t know how to change it, so I left it).
I can’t paste the contents of console.log. Error with max characters allowed for users.
Can I upload or attach the whole file?
console.log (35.9 KB)
I hope that worked. Thanks for all your help and effort
Juergen Mader

Thanks I got the file.

Is Z:\ a network drive? The error it’s giving seems to imply that the drive/folder is on the network (not local on the PC) and that your Windows user doesn’t have access to it. If that’s the case, you would need to enable network sharing on that drive/folder I assume, but without knowing your exact setup it’s hard to give advice on how to accomplish this.

If your Z:\ drive is physically installed in your PC (not over the network), then the only thing I can suggest is to run a Check of that disk:

  • In Windows, go to “This PC” (where your drives are listed)
  • Right-click on the Z:\ drive and choose “Properties”
  • Go to the “Tools” tab and, under “Error checking”, click “Check”

This might take some time to complete, but if there are any errors with the file system it should alert you and/or offer to fix them I believe.

Really not sure what to else to suggest, the error in your log came straight from Windows, so I don’t believe this is a bug in the Downloader itself, but rather either a network/permissions issue or an error in the drive’s file system.

Let me know how it goes,

Actually I just thought of something else.

This looks like it’s an old system folder or something, so it might simply be a permissions issue with the folder. Try the following:

  • Browse to Z:\Users\Gigabyte2\Documents\AivlaSoft\EFB2\Client\
  • Right click the “Routes” folder, choose “Properties”
  • Go to the “Security” tabt, then click “Edit…”
  • Select “Everyone”, then below that, tick the “Allow” box next to “Full control”

You can probably do this for the whole Z:\Users\ folder actually, but maybe start with Z:\Users\Gigabyte2\Documents\AivlaSoft\EFB2\Client\Routes\ to check if it works.

Let me know if that helps,

I tried both ways: the Routes folder had the “Full Control” and ALL the other permission boxes checked (they are grayed out). Also if I press Security>Edit>Everyone the permission boxes are grayed out.
The Z>Users folder also has ALL permissions checked and they are NOT grayed out and I can modify them.
I certainly appreciate your help.
If we can’t get it I will use the Downloader on a remote PC and use it to work around the problem
Thanks again
Juergen Mader

Did you also try checking the disk? As described below:

I have nothing else to suggest right now, it definitely seems to be a permissions issue within Windows. Not sure if the Disk Check tool will detect or fix such an issue, but worth a try I guess.

I tried your suggestion and the “check disk” did not correct it.
So I will run the Downloader on the remote PC where the EFB2 routes folder is located and it works from there. I can access all my other mapped drives (e.g. PMDG>Flightplans and Aerosoft>Flightplans) from the remote PC.
Thanks for all our help, even though it’s not a SimBrief issue.
Juergen Mader