Update for Simlink not working

Hi there,
I’m fairly new to Navigraph (startet some 3 weeks ago) and so far I’m happy with it.
Tho, over the course of the last 2-3 days I keep getting the message that there is an update for simlink. But when I click to install it, Firefox starts with the following adress “download.navigraph.com/software/simlink/windows/Navigraph+Simlink.exe” and then I get this:
stating that the file can’t be read and to try again later or contact the server admin. So after trying it several times, I now contact you :slight_smile:
I tried to manually download simlink and installed it again. That worked, but the message regarding the update still comes. And yes… the update keeps failing.
Any advice?

Best regards,

Servus Frank,
danke :wink: … We are working on a solution. It seems that the signature of the EXE file is not correct (timestamp is missing) and therefore you get this message. Again, we are just checking this please standby …

Liebe Grüße

Hallo nochmals Frank,
please can you try this link please.

Thank you,

Hi Richard,
WOW, man that was FAST!
And it worked! :smiley:
Thank you very much :smiley:

Viele Grüße,

Hi Frank,
fine when this is solved. The problem was your download link what you have posted in your first post, nothing more. You have used an “unsecure” protocol (http) instead of https.

So, for the next time - the better and safer way is to go over our website, directly to the SimLink-Download

Anyways, you´re back again in the Navigraph world - wonderful, enjoy it
Viel Spaß & liebe Grüße

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.