Unable to launch xplane11 after updating AIRAC

I have recently updated my AIRAC to 2206 (last night) and now xplane will not load.
The following error comes up: “Loading navigation data failed.
cycle mismatch between earth_fix.dat and earth_nav.dat. These files must come from the same data cycle.
Please note that X-Plane 11 is not compatible with files made for X-Plane 10”

I have the latest FMS Data Manager installed, the latest version of xplane11 and all other required updates are done. Short of reverting back to using the sim with default loaded charts, I’m stuck.

I have tried doing all the tricks from a post back in January but these haven’t worked

Hi …,

Welcome

You may have copied navdata to the wrong location. I suggest

Make sure X-Plane is not running.

Run … your X-Plane 11\X-Plane 11 Installer.exe with Update X-Plane option to check installed files and restore file structure.

In FMS Data Manager, check you are running latest Version 1.8.9.0421 . If not please download and install FMS Data Manager.

In FMS Data Manager Settings, check your X-Plane 11 path is correct, by navigating to X-Plane.exe.

In Addon Mappings, delete entry X-Plane 11 (11.50+).

Press Scan. Are you now seeing entry X-Plane 11 (11.50+) ?

If yes, in Addon List please select X-Plane 11 (11.50+) and Update.

Cheers
Ian