Subscribtion to navigraph

When im at the Pricing page i click monthly Subscribtion and it says select payment Method but theres nothing there except a loading icon its been there For 8 minutes and im not Able to subscribe and my network connection is just fine Any help?


I cannot reproduce. Which browser are you using?

Could you try it on your phone, does it work better? If you switch browser on your desktop, does it work better? Do you have any firewall and antivirus software, if so does it work better when turning them off?



Im using Google, my phone doesnt load it, My laptop doesnt either When i try to buy it its just stuck on loading with no options

I can even see it refresh a few times in the tabs but nothing happens


As a test try a different browser as your default browser at least till this is resolved.


Just tried it didnt work any other solutions?

If your cant load on phone, laptop or other computer, are they connected via router? Maybe check any router restrictions. Can you try logging in via phone not using router?

Make sure you have AV disabled


All of that is checked i tried it on my comouter and 2 other phones still didnt work even tried switching the wifi but nothing happend still stuck on loading can you try And give me a Redirect link To it? Maybe thatll work.


Nope, Sadly still nothing heres a picture.

Try another computer with a completely separate internet connection?


I already tried that its not working

Use Chrome on your desktop.

Launch the dev console by pressing F12 on your keyboard, and go to the Network tab.

Reload the Navigraph payment page.

Take a screenshot of your entire Chrome window including the Network log, and paste here.

Switch to the Console tab. Take a screenshot of your entire Chrome window including the Console log, and paste here.



Got the solution! For anyone else experiencing This problem just Wait and try The next day It worked for me Thanks.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.