Simlink Crashes since update

Hi Since updating simlink, it crashes instantly upon opening with the log in window appearing briefly before the crash. I’ve tried all the advice from other threads on this forum and it still doesn’t work. Even going back a version no longer works as that version of simlink won’t allow me to log in, i just get waiting user authorisation message. would appreciate any help/fix for this???

Process: Navigraph Simlink [21863]
Path: /Applications/Navigraph Simlink
Identifier: Navigraph.NavigraphSimlink
Version: 1.1.33 (
Code Type: X86-64 (Native)
Parent Process: ??? [1]
Responsible: Navigraph Simlink [21863]
User ID: 501

Date/Time: 2024-01-11 15:08:41.865 +0000
OS Version: Mac OS X 10.15.7 (19H2026)
Report Version: 12
Anonymous UUID: 3FDA21BF-1C5F-A8AF-6DC6-46FD40F9D6D8

Sleep/Wake UUID: CE5A49CE-F859-4C81-AA91-EEE440E8B2B0

Time Awake Since Boot: 170000 seconds
Time Since Wake: 5200 seconds

System Integrity Protection: enabled

Crashed Thread: 0 Dispatch queue:

Exception Codes: KERN_INVALID_ADDRESS at 0x000000000905c000

Termination Signal: Segmentation fault: 11
Termination Reason: Namespace SIGNAL, Code 0xb
Terminating Process: exc handler [21863]

VM Regions Near 0x905c000:

__TEXT 000000010905c000-00000001090c8000 [ 432K] r-x/r-x SM=COW /Applications/Navigraph Simlink

Thread 0 Crashed:: Dispatch queue:
0 ??? 0x000000000905c000 0 + 151371776
1 org.qt-project.QtCore 0x000000010aa70ddb 0x10a86f000 + 2104795
2 Navigraph.NavigraphSimlink 0x000000010908a12c Navigraph::Simlink::Controllers::VersionController::versionUpdated(Navigraph::Simlink::Models::SoftwareVersion*) + 60


We will be releasing a version of Simlink soon that is compatible with old macOS. In the meantime, you can use the legacy version available at Simlink new version wont connect- Mac OS - #12 by vishalahir.

Kind Regards,

Vishal Ahir

Hi Vishal,
Thank you for your reply and the link. I had previously tried those legacy versions and still encountered errors when trying to sign in. Please see the attached screenshot of the errors I get when trying to sign into the legacy versions of simlink. Do you have any other ideas or is it just a case of wait for the new version now?



Based on the screenshot you provided, it appears that your Simlink application is being blocked by an antivirus or security application. To resolve this issue, please allow Simlink to access your network.

Here are a few things to check:

  1. If you have a proxy or VPN connection, please disable it and try running Simlink again.
  2. Ensure that your system date and time are synced with the internet.
  3. Grant Simlink the necessary permissions to access your network.

Please let us know if you continue to experience any issues.

Best regards,

Vishal Ahir