Simlink crashes on startup after updating

Just after updating to 1.1.27 (16.35.44 - Sept. 19th), Simlink crashes immediately on startup. Previous version was running perfectly before updating. I tried to run the older version but it won’t even start now.
iMac 27" Retina 5K 2017/macOS Monterey 12.6/XP11.55.

Hi Eric,

No problems here with iMac 27" Retina 5K 2019/macOS Monterey 12.6/XP11.55.

Try the usual - uninstall Simlink from your machine, restart machine, download and install latest Simlink as per How to install SIMLINK on X PLANE 11 for MAC - #7 by Vimarleo

Restart machine. Run X-Plane 11. Does Simlink start OK?


Hello Ian.

I’m very sorry but no change here : I uninstalled Simlink, even ran a software to ensure that no hidden files were left behind. Then I downloaded and installed the latest version (1.1.27) as per your procedure. Restarted the Mac, started XP11 then immediately I had the attached crash report. Maybe it can help to understand what is going on here ? Fortunately, that does not block XP from starting !!
Thank you very much for your help !

Problem report for Navigraph Simlink.rtf (39.2 KB)

Hello Eric,

Thank you for the error log.
For the log file details, SImlink has no disk access permission.

To fix the permission issue just follow as below,

  1. Close running Flight Simulator and Navigraph Simlink Application.
  2. Open “System Preferences…” → Security & Privacy
    Screenshot 2022-10-04 at 9.57.33 AM
  3. In Security & Privacy go to Privacy Tab and check whether Navigraph Simlink has full disk access.
    Screenshot 2022-10-04 at 10.01.58 AM
  4. If Navigraph SImlink does not have any disk access then please add the Simlink application by the “+” symbol button in the “Full Disk Access” option.

Please feel free to inform us about the issue.


Vishal Ahir

Hello Vishal, glad to hear from you again !

Unfortunately, the problem is still here after giving Simlink a full disk access.
Please find enclosed the new error log. (Same title but with a new content ! :wink:)
Many thanks for your help and have a nice day !
Best regards.

Problem report for Navigraph Simlink.rtf (38.8 KB)


It was issued with access to the Simlink configuration file.
To reset the access right, please follow the below steps,

  1. Close running flight Simulator and the Navigraph Simlink application.
  2. Now take backup and delete the Navigraph folder from the path ~/Library/Application\ Support
  3. Start the Naivgraph Simlink application, it will create a configuration folder again with default settings.
  4. Login into the Simlink application with the Navigraph user.
  5. Done :slight_smile:

Please feel free to inform us of any issue which you face with the Navigraph product.


Vishal Ahir

Hello Vishal, i followed the instructions but it still doesn´t work.

Thank you Vishal. This worked for me on Mac.

Rob Parker

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.