Not able to sign in

My setup

Galaxy A51 - Android 13

What I expected to happen.

Able to sign in.

What actually happened

Im not able to sign in. I spam tabbing the sign in button but nothing happens. Have reinstalled the apk several times, no joy.

Same here. Sign In button does nothing. Using OnePlus 10 with Android 13. Have downloaded the APK again and reinstalled but still not working.

Hello, thank you for the feedback!

What browser(s) do you have installed? Which is the default one?

In contrast to iOS, Android does not provide a way to quickly open a browser window inside the app. This means that we have to open the default browser on your device, and in some cases this could fail for reasons that we do not control.

Looking forward to your responses!

Kind Regards,

I have Chrome, Firefox and DuckDuckGo installed. Default is currently DuckDuckGo. Changing this to Firefox allows the login screen to display and can then sign on.

For me it works with Chrome set to default. The other one installed is Opera and is normaly the default browser. Firefox is also working.

That would be expected then, unfortunately. This seems to be a technical limitation with those browsers, as they do not support Custom Tabs which is generally considered common practice nowadays.
See these sources for reasoning as to why this is:

While this is not a new issue with the mobile beta (it applies to tablets as well), we appreciate the feedback! This is not something that we can easily fix without workarounds that do not follow recommendations and/or best practices, so we hope that temporarily switching your default browser works for you! After all, once you have signed in you should not have to do it again.

That said, we’ll monitor the situation and if a better solution is found, we’ll of course consider improving this!

Apologies for the inconvenience in the meantime!

Kind Regards,

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.

We have now updated the app and it should work consistent and with more browsers. Please update us if you still are experiencing problems.

Kind regards,


Does still not working for me with Opera. Have to use Firefox instead.

It should work just fine with Opera. What versions are you running when it comes to both our app and Opera? Here’s proof from a clean installation:


Nope no luck. Updated Opera and deleted and reinstalled the App. Just working with other browsers.

Sorry to hear that. And the versions?

Opera is version 74.0.3922.70977 and the app runs in 8.20.0-beta-1.

That’d explain it! The app has been released, the latest version is 8.23.0 and is not in beta. This issue was fixed on the 27th of February with the release of 8.21.0.

Please install the released version from the Play store and let me know how that works out for you!

Ok that version is working with Opera. Didn’t know that it was released already.

Anyway thanks for your help!

1 Like

No worries, happy to hear that it is now working! You’re most welcome!