No Simulator Detected Aug 2023

I have updated to 1.2.3 and now I get this message. No Simulator Detected
Nothing else changed between my update and all worked fine before. I have Fenix and PMDG.
In a previous posts to this they mention about simulator location but this has not changed
Many thanks in advance



Please try FAQ - Navigraph Navdata Center could not find/access simulator


Hi and thanks for your reply Ian,
I have followed the information in the FAQ and all is set as shown but still I get the same message No Simulator Detected. I have uninstalled and reinstalled the Hub but still no fix.

Hi @sirtopper ,

I have activated extended logging for your account. Please restart the Hub and try again, we will then investigate what could be wrong.

Kind regards,


Hi again,

It looks as if your Contents.xml file has been corrupted in some way. Please delete it and try again :slight_smile:

Kind regards,


Hi m4rkus,
I deleted the Contents.xml file and started MSFS. I updated some files and then closed MSFS.
The Contents.xml file was not regenerated and Navigraph Hub still says No Simulator Detected. I even uninstalled and installed the hub but same occurs.
Regards sirtopper

Which aircrafts do you have installed which is usually updated by the Hub?

Kind regards,


If I remember right it showed the MSFS, PMDG 737, Fenix A320 and the G3000 for the Honda jet databases.
I did manage to get a Contents.xml file to appear, I had to edit the scenery order, but it still did not work for the Navigraph Hub.
Many thanks for your time on this. Sirtopper

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.