Navigraph Icon missing

I have been trying to get a flight plan to load in msfs2020 but,

  1. The Navgraph Icon is missing from the drop down menu
  2. EFB gives “Error:No flight plan on file for the specified user”
    Have downloaded all the software from Hub.
    When going to cockpit after pressing the “Fly” Icon, I get a message saying connection has been made.
    Been struggling with this issue for a couple of days and am now totally confused. Any solution, gratefully received.

Hello! Welcome to our forum.

I assume that you mean the panel toolbar along the top of the screen in the simulator? If that is indeed the case, please make sure that this product is installed in the Navigraph hub:


Please also verify this by making sure that your community folder indeed does have a folder called navigraph-ingamepanels-charts. The icon should show up then!

I am not sure what you are referencing here, but we do not make any EFBs and we do not show any such messages so I think you are asking in the wrong place unfortunately :sweat_smile:

Kind Regards,

Apologies! As I said, I’m confused. Not long into FS and its a big cliff to climb!
I’ve checked community folder and the folder navigraph-ingamepanels-charts is there -I had already downloaded all the files from Navigraph Hub…

Are you using the Steam or the store version of the simulator?

Have you installed any other panels successfully?

Store version.
Sorry not sure what you mean by other panels. I am using a flight traffic injector from FlybyWire. Is that what you mean? like I say I’m pretty new to this whole scenario.
Thanks for your prompt replies.

Our Charts in-game panel is what you appear to be having issues with, and there are many other in-game panels so I was wondering if you had any other panels installed, such as this one for example:

The reason why I ask is that the issue is very likely to be unrelated to our panel specifically. I have not seen an issue like this previously, but I am guessing that it could have to do with filesystem permissions in your community folder! This is easy to rule out by installing a different panel to see if that works as expected.

Perhaps you could try installing the one linked above to see if that one shows up?

Kind Regards,

Malte,First of all, thank you for your patience over this. I’m very grateful!
Yes, it’s there and opens when clicked with a small square showing aircraft origin, destination and a few other bits of infornation, but not the (to me anyway) huge amounts of info shown on your webpage example. I presume that’s the paid-for version.
Thanks again.

Of course, I am here to help!

Sorry, what opens? You installed the SimBrief panel and that worked without any issues?

The panel that I sent a link to is not made by us. I wanted to see if any other panels would work for you without any issues since you have so far been telling me that the Navigraph icon does not show up inside MSFS, which is puzzling.

Kind Regards,

Sorry! Confused again. I thought it was a navigraph offshoot. Yes, it loaded and the icon is present.

Not sure what to say…

Please follow these steps:

  1. Close the Navigraph Hub and the simulator
  2. Open the Community folder
  3. Delete the navigraph-ingamepanels-charts folder
  4. Download the panel from here: (40.5 KB)
  5. Unzip it and copy the resulting folder (should be named navigraph-ingamepanels-charts just like before) to your community folder
  6. Start the simulator

Do you still not see it in your toolbar?


I’ve done that. Still no result.

Would it help if I sent a pic showing the contents of the Community Folder?

Also, and I don’t know how relevant this is, but whenever I click the Navigraph Icon on the task bar, it re-loads the hub. Is this normal?


No, unfortunately not. As long as you are sure that the folder I sent you is in there, it should show up!
The file I sent you comes directly from my simulator, in which the panel shows up just fine…

This is unrelated to the topic, but depending on what it looks like then yes. Feel free to open a dedicated topic, including a video of what’s happening!

At this point, I am at a loss. Can you find the panel in the content manager? Just search for “Navigraph”, and the panel should show up in the list:

Kind Regards

Hi, after latest update, the contents in the folder ‘navigraph-charts’ have been deleted.

This results in no shortcut / executable to run the charts.

However, the charts work from within MSFS2020.

I think my issue is related.

I do not recognize this directory, it is not one of ours. We have not released any updates to the panel, only the interface within it. It is technically impossible for an OTA update like that to remove files on your computer - that would be a huge security flaw in the simulator!

Did you try the steps already provided in this topic? Does the panel show up as “installed” in the Navigraph Hub?

Kind Regards,

Sorry for delay!

It is present

See attached

Nav Content Mgr.docx (113 KB)

That’s odd. I’m afraid that I am completely at a loss as to why this would not show up in your toolbar.

Perhaps you accidentally hid it when customizing the toolbar?

Yes. That was it! Thanks!
I don’t know how I turned it off, though: never looked that far down the menu!
Thanks again. Very grateful for your help!

1 Like

I am happy to hear it! I can’t explain it either, but the main thing is that the issue is resolved.

Thank you for letting me know about your success!

Kind Regards,