Navigraph Hub - Unable to Update In-Sim AIRAC Data

A new problem I am having is that I cannot update the AIRAC cycle for any of the products on the “Installed in Simulator” tab. Clicking on any of the green buttons does not result in any actions; I don’t get any error messages but the buttons don’t change color to indicate the update is being performed or that anything is happening…the app just locks up and all I can do is eventually force-quit. this all worked without any issue until the recent changeover to the new app.

FWIW the FENIX A320 data on the “Installed Outside Simulator” tab updated 100% okay on the first try. It’s only the ones on the first tab that can’t be updated.

BW the only change to my simulator installation that I’ve made recently is that I purchased and installed FSiPanel to use with the sim, however I noticed that it is not shown in the Hub products list and since there isn’t a way to do a manual scan from the Hub I’m not sure what’s going on there. Could FSiPanel be messing up the other AIRAC updates somehow?
NG HUB Capture

Hi Kevin,

We have turned on some extra logging. Please try again so we can see any errors…

FSiPanel shouldn’t affect things, but you could test by uninstalling it.


Hi Ian,
First, thank you for the super quick reply…much appreciated!

Okay I just tried two more times to run the updates via the Hub app, but had the same results. First I tried to update the base NG AIRAC cycle, then I tried to update one of the PMDG aircraft. As before after each attempt I had to force quit the Hub app as it became completely unresponsive after I clicked the Update button each time.

thanks for your help.


Is there anything particular about your community folder, or is everything MSFS default? I am especially thinking about if you have moved the folder to some custom location on your system (if so which path?), or set any custom permissions?



I have a dedicated nvme drive that I install everything related to MSFS on (if it will let me). So my community folder is on that drive, as in (Drive Letter):\MSFS2020\Community. I have no special permissions attached to these folders and this has never changed. And as I mentioned before the FENIX updated normally this time.

However I think the key thing here is that this is the way it has always been configured, and until this update cycle it always worked just fine. the previous update cycle worked without an issue; clicking the green update buttons resulted in the updates being applied as expected in all cases. I have not made any changes to my basic sim configuration since that update cycle.

As far as I am aware the only change since then was that I think you pushed out an update to your NG data app…although I’m not certain of the timing of when that occurred it might have been earlier.

Btw…this weekend I had some spare time so I did a complete uninstall of the NG Hub app and everything associated with it I could find (cache, reg keys, etc.) I downloaded a new copy of the app and reinstalled however I’m still getting the same behavior.

@Kevlar01 Do you still have these issues? From our side it looks like everything works like normal and you have installed the latest versions of all your packages :slight_smile:

Kind regards,


I did finally get all of them to update by changing the permissions of the various folders your app creates and modifies for each product, however I’m not sure why I had to do that in the first place. It’s not something I would have changed myself for any reason and the folders were in the same Community folder I’ve been using all along.


It could possibly happen if you run the Hub in admin mode once and update packages. I am a bit surprised you did not get an error message about it though :thinking:

Okay. I typically run ALL of my programs and apps in admin mode since that usually helps avoid issues just like this one, instead of creating them. Anyway I guess it is working again.

Btw regarding updates to FSiPanel (which is where this all kind of started for me) will I have to run the manual update for that program each cycle? I don’t see any way to add it to your Hub app when the app doesn’t find it on its own.


1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.