MSFS VR Charts App's Interface too large, cannot scale it down

The Charts App in VR. The interface, i.e. the boundry and the clickable toolbar etc. are massive. The + and - blocks on the lower right side do not resize these items down to a reasonable size. I can shrink the window itself down but the interface stays very large and takes up the whole window.

I had this same problem last year when I was an ultra subscriber and so I just unsubscribed as the Charts app is the whole purpose of paying for Ultra. I was hoping that it was fixed but it seems to actually be worse now.

I took some screen shots to illustrate the issue.

Is there some setting I am missing? See how big the + is in that shot…it will not get any smaller. And the tool bar and such are all as small as they will get as I already made this large so I could get to the - sign to make the interface smaller…that is the smallest it will go to. If I expand the window so I can see the - sign the thing window is huge, and even then its not big enough to see the whole tool bar. It just takes up so much room its useless in VR. About the best I can do is make it giant sized and they try to push it way out into the distance by grabing it and leaning forward, then dropping it then grabbing it again and leaning forward and dropping it again so that its about 15’ out the window in front of the plane.

so here it is in REG view and its usable…attaching another screen shot.

That is usable in REG screen, but in VR to get it to look like that it will take up the whole cockpit.

Essentially I am saying that for VR you need to make it so the App itself can be reduced a whole lot more and that when you shrink or expand the window, what ever setting the person has for the App, it stays like that.

Either that or show me what I am doing wrong? Please, as I would love for this to actually be usable in VR. Do you all use VR? Have you not experienced this issue? Maybe its my headset? I use an HP Reverb G2, with a RTX3090 Card so its about as good as it gets for VR clarity.

One more thing…those screen shots are of the VR viewer, its 2D so while it looks like you could just size it up (the window) and it would work…believe me in 3D that does not work…the more you size it up in 3D it becomes ridiculous to your eyes…like as if you stick your head right up against a 2D screen…very uncomfortable.

Hi there,

I’m sorry to read that you are experiencing a too large interface in the MSFS In-Game Panel in VR.

The headsets we have available for testing are the Oculus Quest 2 and the HTC VIVE Pro 2. We have tested the In-Game panel on both these headsets, and can unfortunately not reproduce this issue. Attached is a print screen showing how it looks with the Oculus Quest 2 when the window is scaled down to a fairly small size, just enough to still be able to read the information on the chart.

We are aware that there have been discussions in forums where G2 users have had issues with that headset in particular with regards to textures inside MSFS aircraft.

I am very sorry for the inconvenience, but at this stage, it seems like there is not much we can do with regards to this issue.

Kind Regards


SAme problem for me with the G2 . Please try to fix this error! We all pay for this app!

Hello Lukas! Welcome to the forum.

Sorry to hear that you’re having issues with the panel. However, please keep in mind that the issues related to the G2 headset are way beyond our sphere of influence, there is nothing we can do about them. The headsets that we own and test with do not have the mentioned issues.

Please also note that the panel comes with your subscription at no extra cost, you’re not paying anything to have a fully functional panel.

With all the above said, we truly are sorry for the inconvenience. If there is something we can do about the issue in the future, rest assured that we’ll do it right away!

Kind Regards,

I don’t understand how this is headset related.

Are you saying that with (for example) a quest 2 when you click on the + it zooms the map and not just enlarged the entire interface? Are they not both just sending the same event to the panel?

In any case, the G2 is one of, if not the most used headset for flight simmers. May I be so bold as to suggest perhaps you purchase one. It’s not like they are expensive. I mean what are you saying here, sorry won’t fix? What can I do, do you need a video showing what’s happening? Do you want to give me a debug build to log events? Work with us please. I really really hope this is fixed in the new panel.

I fly almost exclusively VR these days, the panel is almost completely unusable to me. If and when the G3000 refresh drops that drops chart integration, the ultimate subscription will be next to useless to me, and as I’m sure you can image, I won’t be resubscribing in that case.

Sorry for any confusion, I’ll try my best to clarify!

No, there are two sets of zoom buttons in the panel. The large ones to the right scales the UI, a (rather hacky) workaround that is needed since it is not possible to determine a suitable scale automatically from the environment that the panel runs in. The other, smaller set at the bottom-left is used to zoom the map, an action that can also be carried out with mouse scroll events.

The current situation is that the symptoms described in the OP have so far only been reproducible in G2 headsets. There are also other known issues with that exact headset with regards to MSFS, as mentioned earlier. Unfortunately, there is nothing we can do about the issue in the OP since it is out of our reach and we do not have the necessary influence in the simulator development to alter this behavior in any way.

With the above said, it really does sound like you might have a similar but not identical issue? Your initial question, as answered above, seem to indicate that the “normal” zoom buttons do not show up for you for some reason. If that is the case, please advise and we’ll open a separate thread!

Rest assured that we would do something about the issue in the OP if we could! We want the panel to be usable for everyone, G2 owners included.

Kind Regards,

Hmm, well my mind is blown. I have to apologize. The small ones are working, it’s just that the other ones are so in your face that I seriously never even saw the ones on the left. Especially because I almost always have the airport chart selection thingy open on the left, in which case these buttons are hidden.

Then when you open a chart, you get yet another set of zoom in/out buttons. So I think this is not so much a functionality issues as much as it is just a UX issue.

I kind of think map/chart zoom should be fixed position, and unified, and the UI zoom thingy should be … I dunno somewhere not so in your face. My 2cents.

Thanks for the clarification.

Note: I have a video of my figuring this out as I wanted to show you how the buttons not work, but then I saw your message and noticed them.

1 Like

Glad to hear that it worked out! They’re really easy to miss.

We’re aware of this and it really is unfortunate, but as mentioned it is more of a hack than anything else. We put it where we thought that they would be the least in the way, but you’re completely right in that it is not perfect. Apologies for the inconvenience!

Kind Regards,

This issue is occurring with the Varjo Aero as well.

It was never a problem until sometime around the end of February. I remember all of a sudden it seemed like the in-game chart were being “zoomed” back, and I couldn’t figure out what I was doing to affect it. The edges and UI and map text is all microscopically small.

When I zoom in and out on the map, it temporarily displays the text at a reasonable size and then sort of “re-scales” it back down. Its like trying to read a microfiche film with the naked eye.

Please contact me if there is anything I can do to help. This issue really makes VR flying less enjoyable than it was back when the charts worked just fine.


Hi there! Sorry to hear that you’re having issues with the scale. Perhaps I can help somewhat at least!

First - please note that you are reviving a thread that was created before the new panel was released. We do not support what is now considered the old panel anymore. If you have not updated to the new version, please be aware that we will not make an effort to fix the old version.

This said, in a recent simulator update, there was a major regression when it comes to the scale of panels in general. This partially broke our new panel as well as others, and AFAIK there is no easy fix that we can do at the moment. You can follow that discussion in this thread:

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.