Load as active MSFS flightplan doesn't do anything

As title. I build a route with the in-sim Navigraph window, then when I export it using the ‘Load as active MSFS flightplan’ nothing happens… help.

Hello Martin! Welcome to the forum.

The “Load as active MSFS flightplan” takes your currently planned route and exports it to the simulator directly by manipulating the flightplan. This can be seen in GPS units such as the G1000 instruments.

What exactly is not working? The above screenshot was taken just moments ago using the latest simulator and panel after selecting the mentioned export option.

Kind Regards,
Malte

And perhaps more importantly: What aircraft and/or instrument are you expecting to receive the flightplan? Developers such as FBW have made their own flight computer implementations that intentionally do not use the built-in flightplan (the one that we update) because of it often lacking the information and stability that they require.

Hi. I’m just flying the default Cessna 208B Caravan in MSFS2020. Nothing changes is the G1000 when I load the Navigraph FP as active.

Hello again! That is of course not intended and since I’m not able to reproduce it myself, I will need some more information from you if possible.

Specifically, I’m interested in whether the logs in the simulator contain anything out of the ordinary. Please follow these steps:

  1. Open http://localhost:19999 in a browser while the simulator is up and running
  2. Scroll to the bottom of the list that appears, and select the link containing the word NavigraphPanel
  3. In the interface that appears, select the “Console” tab located along the top of the screen
  4. Focus the simulator window and try to load a flight through the panel
  5. If still unsuccessful, please open the browser window, scroll to the bottom of the log and take a screenshot, then attach it to your next post.

Let’s get to the bottom of this! Our solution is quite fool-proof but there have proven to be scenarios where the simulator simply does not work correctly in this area, and in that case, it is out of our control. If the issue lies within our implementation, we will of course do our best to fix it!

Kind Regards,
Malte

The above steps will require the developer mode to be enabled inside the simulator. Please advise in case you do not want to enable it and if the issue is still occurring, and we’ll try something else!

Kind Regards,
Malte