Installation of Simbrief

I have been trying to upgrade Simbrief 1.6 to 1.7 without success. Thought it would automatically thought that 1.7 would auto the installed 1.6 but no luck. unistalled 1.6, tried to load 1.7 but no luck there, now I have no Simbrief loaded and cannot load 1.6 or 1.7

Hi, you say you have “no luck” installing version 1.7.0. Have you tried double-clicking the installer that you downloaded from the Downloads page?

Can you provide a screenshot of the error you’re seeing?


Thanks for the reply.

I have downloaded the Downloader 1.7 from your web site using both Firefox and Microsoft Edge. The files were placed on my Desktop in the form of an App.

Each App has the Run as Administrator Shield placed on it.

I have clicked once and also doubled clicked on each of the downloads plus trying to start the downloader outside of the App. A small blue rotating circle appears each time and rotates a few times then disappears. Nothing happens after that, No error messages given.

Presently I have resigned to get to SimBrief via your web site which takes a little longer because I have to open up my browser and then call for the SimBrief website sign in and then plan my flight.

Best Regards,

John Burden

I did a search of my C: drive and came up with these crashes at my attempt to install SimBrief 1.7 My system did not display these crashes
Processing: AppCrash_SimBrief Downloa_18ef6dc08a1061998d7658b3073b8d73d7a399_075a1a75_ec19b2ab-5ad0-48fd-8125-5f841c904074…