In-Game Panel shows blank

My charts show up fine standalone Charts and even inside PMS750.
This morning the In-Game Panel opens, says it is loading, then display a blank screen.

I updated via the NavData Centre but still nothing.

Any suggestions as to what else I might try. It was working fine yesterday.


I am having the same problem. Had it working last night in demo mode, last night I updated my subscription to ultimate yearly to get all features and this morning the in-game panel opens, says it’s loading and displays a blank screen. Server issues prehaps?

Oh good. It’s not just me :wink:

Same here, too.
Removed and added Simlink and the navdata center software with no joy. Also, getting conflicting version info within the ND Center showing the ingame charts as both V1.1 and 1.2. Removing/updating 1.1 does nothing

Sorry guys! The two versions being available at the same time was a mistake on our end. You should now see only one version available, v1.2. This update brings a workaround for sign-in persistence, so please go ahead and give it a try and let me know if it works as expected!

Regarding the initial issue, are you still seeing a blank page? I have tried to reproduce the issue, but I have not been successful yet.

Kind Regards,


I am having the same issue and unfortunately after your advice the panel is still blank. I can not login or get the QR code to login.

I have uninstalled everything including navdata center and afterwards re-installed everything including v1.2, but this did not fix the issue.

Kind regards,

Having the same problems after updating to v1.2 screen is blank with no login or QR code to login with.


I can conmfirm that MSFS navigraph charts are truly broken. I cannot get the charts from the toolbar (just a blank screen). I have tried uninstalling and reinstalling and have had the conflicitng versions come up. I have updated both versions, tried updating just one version etc, etc… It is a complete and utter mess.

Are Navigraph trying to copy Asobo with non-existant quality control?

Hi guys,

Please standby, we have found an issue with the recent release and are working on a fix which should be available shortly!




Thanks for the quick work on the problem. I’m guessing you are not following the Asobo model. :wink:


Thanks for getting straight on it. Good to see you guys are not trying to emulate Asobo!

Kind regards


Hello everyone! Sorry for the trouble. I believe I have tracked down the issue.

The release has been hot patched, may I please ask you guys to remove and then reinstall the panel in the NNC? Please let me know if things are still not working!

Again, sorry for the inconvenience!

Kind Regards,


Did as you asked and all is working now. Thanks for the quick fix!

1 Like

Glad to hear it Edward! Thank you for reporting back, much appreciated.

Have a nice day!

Kind Regards,

Thank you. Updating the in-game panel via the Navigraph app fixed the issue.

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.