Garmin 1000 Simbrief charts not working in MSFS 2020

I just updated MSFS to the latest version. I have the unlimited subscription, installed the G1000 plug in via the hub. I followed the install tutorial. when I open an airplane and get ready to import a flight plan, no navigraph charts are visable in the MFD and the “charts” button on the bottom of the MFD is not bold, but is greyed out and unresponsive. The VFR-IFR charts option and flight plan option is also not selectable with the rotary knob. This is in the Cessna 172, Kodiak and the Diamond with the G 1000 . I’ve tried uninstalling / reinstalling the navigraph plug in via the hub. I also uninstalled/reinstalled the WT plugin for the G1000. The Navigraph “sign in” page has never popped up with these planes like with all other aircraft when using the plug in for the first time.
Thanks for your help!

What actually happened

Please describe what happened in a way that enables us to find the problem
without follow-up questions. For instance, saying “the charts do not work”
or “login is broken” doesn’t help. To the extent that it is possible, please provide clear steps to reproduce the
problem. Screenshots and error messages are helpful and encouraged!

Hi Nathan! Welcome to the forum and thanks for the report.

This is very likely to be caused by something else that is incompatible with our plugin. So far, the only such report we have for the G1000 is a C510 modification, do you have anything like that installed?

If not, check the content manager for any modification that could interfere by making incompatible changes to the G1000! Older addons that changed G1000 behavior had to overwrite it, which means that plugin support is not included and our plugin won’t work.

Kind Regards,

Thanks for the response Malte, the only avionics plug-ins that I am currently using are the Working Title G1000, 3000, 5000, TBM and the TDS GTN 750. I don’t remember a mod for the C510 but I’ll double check this evening I did uninstall the WT mod for the G430 several months ago as it was causing issues with the TDS GTN 750 function. I do have a lot of add on aircraft purchased through the marketplace but I believe they all use either the default MSFS G 1000, 3000, 5000 series, the TDS 750 or the native systems that were included with the aircraft like the PMDG 737 Phoenix A32O and the default Citation. The Navigraph in-cockpit charts panel and flight plan import function seem to work like they always did with these other aircraft. It’s only the G 1000 that I’m having issues with.
Thanks again for any suggestions you might have!

Did you have time to check? I know it is probably a lot of trouble, but I am 100% sure that you have something incompatible installed which would be solved by removing all addons and putting them back one by one until you find the culprit.

The last user who had a similar issue was adamant that he had already checked all addons, but in the end there was indeed one that was incompatible. You can follow the whole discussion here (unfortunately not in the forum).

Kind Regards,

Yes, thanks! I didn’t see any plug ins other than the TDS GTN750 that looked like it might be related to avionics so I’m going to see if I’ve missed an update for that product that might be causing a conflict. I’ll also try uninstalling the TDS product and see if the problem persists. I’ll let you know how that goes. Are we still supposed to be using the G1000 -3000-5000 Working Title mods that are available in the marketplace or were those mods included into the native avionics in recent MSFS updates? Thanks for your help!

Ok, problem solved! You were correct sir. I mistakenly thought the C510 was the CJ-4. I updated my Cockspur Cessna Mustang ( C-510) from ver,1.0.1 to the latest version: 1.0.3 and everything is working as it should now. This new navigraph app has breathed new life into the MSFS G-1000 series planes for IFR pilots!
Thanks for the assist!

No worries! Happy to hear that the issue has been resolved!

Thank you for the kind words. See you in the skies!

Kind Regards,