Garmin 1000 GPS freezes

With Navigraph installed Garmin 1000 GPS freezes, when trying to input ICAO code in the GPS. It does that with or without mods. When removing Navigraph data, the Garmin 1000 GPS works fine. Navigraph Charts is OK.

Try to input a direct in Garmin 1000 GPS and it freezes when reaching second input, as in the “S” in ESOE. It’s only the GPS in the MFD that freezes. PDF is fine.

It is doing it in current MSFS version ( and the one before. Two versions ago, it was OK.
My friend have exact the same problem.


thanks for the report - we have read this in the old forum too … We are aware of this but we are still not 100% sure, if this is really a related data issue. We are working very intensively on an data-update since 2 weeks, which should improve something. One of the new features is, that we can now suppress all underlying data. Means, no double waypoints, no double ICAO codes or similar else. This could be the reason for flickering and also for the freezes because the sim must manage currently two datasets.

Again, we are still not ready because this is a “critical” update for us, when we suppress the default dataset. The testing effort in the new sim is much more larger as in other sims due several reason.

We are still working on it and we hope we are ready soon - hopefully the freezes can be fixed with this update also, but as I wrote - we are not really sure, if this is really a navdata issue.

Thank you,


Sorry to say, but the bug is still there after the update of the AIRAC Cycle 13 Rev.1! I tryed from LOAV to set Direct to LOGG. If I set the L its OK if I want to set the O then it stops and freezes. Also if you now press the FLP Button the flightplan is black! If I delete the Aircycle and do the same then it works!

updated to 1.0.0` beta 19 with Navdata 2013 rev.4, still crashing once you start to enter the second letter of waypoint

Sorry can´t reproduce

No CTD …

I can confirm that it now works with Navdata 2013 rev.4. Thank’s for fixing this bug. But i use 1.0.0` beta 15. So maybe there is still a Problem!? Is it possible to know where the problem was?

1 Like

Hello, indeed the G1000 is still freezing if you try, for example, a direct to the NDB of Amalias (AML) in Greece.
There should have been a couple of duplicates of AML, but Navigraph’s data only finds the NDB of Agadir in Morocco, and if you execute the direct to there it freezes.
If instead of performing a search of the NDB you’ll execute the direct to from the list of the nearest NDBs then you’ll have no problem and no freeze.
With the original navdata the situation is similar, you’ll not be able to find anymore the duplicates after the recent updates, the only AML available is the one in Morocco, but it’ll not freeze if you’ll execute a direct to there.
Most probably this is also happening with other navaids that have duplicates, but what is important is to understand why the duplicates are not showing up and if that is somehow the direct cause of the freeze.


Hi Valeriano,
sorry, I can´t reproduce your report. I´m sitting at LOWW and when I try a “direct to” in the G1000 I can select the AML (in Greece), no freeze. When I hit activate - no freeze.

Using: AIRAC 2013 revision 4 & Navigraph Navdata beta client 19

About the duplicates:
When you look for AML in the worldmap you see also both NDBs (Greeze and Marocco). When you go to GMAD as an example, which is near AML in Marocco you will see that you can only select this NDB from the list - you will not get the AML in Greece. I don´t know the rules behind the G1000 in the sim about the ranges but it looks like, that they are looking for the navaids in a specific range only. That´s not what we have in our hand.

I have tested the same in the TBM930 and here you see the different/duplicated AMLs:

It could also possible, that this is a G1000 limitation, I don´t know. But the main point is:
I can´t reproduce your freezing in the G1000. Please check your latest client and the latest revision. Possible, remove and install the AIRAC again via the latest client beta 19.


Hi …
It is highly recommanded to use the lastest Navigraph Navdata client also … so please remove the AIRAC, uninstall your beta 15. Install the newest beta 19 version and then install the AIRAC again. It´s is very important, that you remove the AIRAC first!!

Thank you,

OK Thanks for the hint. I installed the newest version beta 19. And i can confirm that it works Cessna172standing at KSFO set direct to SATH. And it works fine. Also NDB’s. No problem at all! Hope this will help now. I’m happy!


This topic was automatically closed 5 days after the last reply. New replies are no longer allowed.