Can't sign in to website

Hi, I’ve just created this account with no issues. When I try to sign in to my main account on, it asks for my login details when i press submit it asks me to sign in again.
Turned antivirus off
Turned firewall off
Tried google chrome, Firefox and edge. Each time setting as main browser. Nothing works and I’m at a loss.
please help

1 Like

Same issue here, but with an existing account with an ultimate subscription. This account worked a few weeks ago.
I am using google chrome. After entering login credentials once, the website is leading me to the “New version of Navigraph Charts is coming…” page. When a click the sign in button again, it just reloads this page.
Same results with microsoft edge browser.




Make sure you enter your correct email address at login, not just user name. Make sure this email address is for the account with subscription.


I used my email address. On my mobile i can sign in. But this does not help because i want to download the winows apps.

Now i was signed in after a refreshed the website :slight_smile:

Great to hear it is resolved.

Happy flying