Cannot Download FMS Data

Why is it that when I try to download FMS Data, the button for OS and Windows are both unavailable, and the only option I have is “Manual installation.” I don’t want to have to download things for every app separately on this PC, and I shouldn’t have to. I have an active subscription. So what is the problem? I’ve tried different browsers to see if that was the issue, with no luck. So it’s obviously not a browser problem.

Hi …,


For which OS and FS?

For MSFS please see FAQ - How to install/update the Navigraph Navdata Installer

For non MSFS, please download, install and run FMS Data Manager. When prompted to Scan for addons, please do so. Your OS, FS and addons should be detected and you should be able to update addons.


That’s what I am telling you. When I go to that page, the buttons for downloading and installing for Windows and for Mac are unavailable (greyed out). The only choice I have is “Manual Installation.” I don’t understand that. I’ve tried with both Google Chrome as well as MS Edge. I managed to work around it by getting the actual source link from the button, but I really shouldn’t need to do that. Letting you know that there’s something wrong with your page. I am putting a screenshot here to show, but I am blind, so I hope I captured it correctly.


The screenshot you show has dark blue Download buttons with white text, for FMS Data Windows and FMS Data macOS, as on my system. The dark blue is the same colour as the background for the page.

Can you please check. Maybe try clicking at right of white box where you have shown, in case it is simply not displaying correctly. Have you any special settings in Windows which might alter this display.

Maybe try a different default browser such as Chrome as a test.