Bad URL, Navigraph on Desktop and Avitab/Simlink

Hello all,

I hope all are well and Covid safe?

I have been experiencing a problem since about the time of the new Simbrief release.

Whenever I try to log into my Avitab account or Navigraph Charts Account, when flying either X-plane 11 or 12, I receive the following error message on the provider page in the Avitab tablet –
Error HEAD error: URL using bad/illegal format or missing URL

Have tried the following solutions
Disconnecting and reconnecting the router
Deleting all cookies and temporary files
Disconnecting Windows 10 Firewall.

All to no avail

The Avitab tablet will show the basic airport information but no charts

Likewise, when I log into Charts.Navigraph and sign in, the page appears but will not connect to the current flight? Nor will it download my flight plan from Simbrief?

I should point out that I currently run X-Plane 11 on my “C” Drive and X-Plane 12 on and external “Z” SSD Drive, however, this has never been a problem before and I have run NavigraphSimlinkSettings.exe and made sure that Simlink is reading both X-plane 11 & 12 in the correct drives.

Can you help please?


We are not able to reproduce. Have you reported this issue to the Avitab developer?

Could you please be more specific about your issues with Charts? What do you mean by “will not connect to the current flight”? And what happens when you import from SimBrief? Could you please share a few screenshots of both these cases.



Hi Stephen,

Thank you for the quick reply.

I have had difficulty finding contact details for Avitab help desk so I will keep looking?

With respect to Navigraph I have attached three screenshots showing the issue I have with Charts.

  • Import from Simbrief - shows the flight plan lodged with Simbrief via Walker Air Virtual Airlines, successfully imported via Simbrief.
  • Successful Import -Shows this Flight plan is ready to be downloaded to Charts for use.
  • Unsuccessful Flight Load - This is where the problem begins. The flight does not load with the white coloured watermark moving across the screen in “Origin” & “Destination” as if it’s about to load, until it times out.
    Your thoughts please.

Thanks again


I don’t know the Walker Air Virtual input. But maybe you could upload the Simbrief Flight and we can try to load it.


Hi Ian,

Walker Air just uses the Simbrief Flight Planner nothing else -

Flight plan below I am flying now WAT 2704
RPLL/13 N0454F340 SIRC2C SIRCA L628 ARESI/K0839F340 L628 PCA G474 ANINA/N0450F340 G474 VEMKO M633 DULEM DOLN3D VTBS/01R

I just can’t load it onto Navigraph Charts or any flight plan for that matter



Not able to reproduce this either. I can load your flight plan without any issues.

Could you please disable any firewall and/or antivirus in case something is blocking some network requests? Could you possibly try it on a different device (do you have a phone or tablet available to download the Charts app to), or alternatively connect your PC to a different network (mobile broadband)?

Kind regards,


Hi Stephen,

Thank you and Ian for your input.

Please close the ticket.

It appears that it was my routers firewall causing the issue. I have an EERO WiFi extender that comes with firewall protection. I once I switched off this firewall Navigraph and Avitab worked perfectly.

Once again thank you for your time and suggestions and keep up the good work I love your product.




Glad you found out what it was!

Kind regards,


This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.