AIRAC 2208 rev. 1 not available in Navdata Center

I received an email notification that AIRAC 2208 rev. 1 was available. I was able to download it in the Data Manager for XPlane 11 but not in the Navdata Center for FS2020, which is still listing 2207 as current.

can you confirm, that you´re using the latest Navigraph Navdata Center v1.0.10? You see this on the bottom line in the middle:


1 Like

Yes, I’m using 1.0.10.

Please, can you upload screenshot, that we see the wrong cycle number? … and you don´t have any “UPDATE” button (green one)?

Thank you,

Rebooting computer fixed the problem.

I am using latest SU10 beta (Steam Version). I can find AIRAC Cycle 2208 rev.1 in my Navigraph Navdata Center. But when I tried to update, it fall into infinite “INSTALLING” state. My Navigraph Navdata Center is 1.0.10.

Checking activities in Task Manager, there is a over 80Mbps traffic triggered in about 1 second when I pressed “INSTALL” and created 2 folders in “Community” folder. But everything calm down with no CPU activities and network traffic again.

2 folders installed in “Community” folder:
“navigraph-navdata”: 94MB
“navigraph-navdata-base”: 9.44MB.

But I am not sure they have all the files they should have.

When I close the app window, totally quit Navigraph Navdata Center in system tray and relaunch it again, AIRAC Cycle 2208 rev.1 showing “REMOVE” button, meaning that it claim update/installation was done. BUT, when I tried to “remove” it, it fall into infinite “REMOVING” state again.

I have tried reboot but the situation is still.

I have also updated AIRAC cycle in Navigraph FMS Data Manager for RealTraffic and SimToolkitPro. They all finish update within a minute with no problem.

Is it a compatibility problem on SU10 beta?

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.